aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-13 00:57:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-13 00:57:56 -0300
commit965d0b2257a9783d587411dc7454dd83567f9a6c (patch)
treedc0e7d354a705dac020ac5586941be000e6d790e
parent86dcd2a32d4765b0e172415f7ad4ae2448280ef2 (diff)
testing/cloud-init: fix bash-completion
-rw-r--r--testing/cloud-init/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/testing/cloud-init/APKBUILD b/testing/cloud-init/APKBUILD
index 4c6d4f6a622..d57a8e7376f 100644
--- a/testing/cloud-init/APKBUILD
+++ b/testing/cloud-init/APKBUILD
@@ -1,25 +1,23 @@
# Contributor: Matt Dainty <matt+alpine@bodgit-n-scarper.com>
-# Maintainer:
+# Maintainer:
pkgname=cloud-init
pkgver=18.5
-pkgrel=2
+pkgrel=3
pkgdesc="Cloud instance init scripts"
url="https://cloud-init.io"
arch="noarch"
-license="Apache-2.0 GPL-3.0-only"
+license="Apache-2.0 OR GPL-3.0-only"
depends="e2fsprogs-extra python3 py3-configobj py3-jinja2 py3-jsonpatch py3-jsonschema
py3-oauthlib py3-requests py3-serial py3-six py3-yaml"
makedepends="py3-setuptools"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch $pkgname-openrc"
-source="https://launchpad.net/cloud-init/trunk/18.5/+download/$pkgname-$pkgver.tar.gz
+source="https://launchpad.net/cloud-init/trunk/18.5/+download/cloud-init-$pkgver.tar.gz
add_distro-alpine.patch
cloud.cfg
hosts.alpine.tmpl
alpine.py
"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$builddir"
default_prepare
install -m644 "$srcdir"/alpine.py \
@@ -27,17 +25,14 @@ prepare() {
}
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir" --init-system=sysvinit_openrc
install -m644 "$srcdir"/cloud.cfg \
@@ -45,16 +40,17 @@ package() {
install -m644 "$srcdir"/hosts.alpine.tmpl \
"$pkgdir"/etc/cloud/templates/
+
+ mkdir -p "$pkgdir"/usr/share/bash-completions
+ mv "$pkgdir"/etc/bash_completion.d "$pkgdir"/usr/share/bash-completion/completions
}
bashcomp() {
- depends="bash"
+ depends=""
pkgdesc="Bash completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- cd "$builddir"
- mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
- cp bash_completion/$pkgname "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+ amove usr/share/bash-completion/completions
}
sha512sums="f89ee636922e33b5b2dcb5230763404fbeee148e28b8f61bf5b2f1f07000f960f9d38545dfb7bcbe9afb8253f77d66c94b39e9a159715b44a440a7cbe1fe1aeb cloud-init-18.5.tar.gz