aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-07-13 18:48:37 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-07-13 18:51:26 +0200
commit96d355a76e7b7cdb9a76090bbe8ef57118149d60 (patch)
treeb0c190ed6fec851ddce29f1ae84047a7b2c809d5
parentea3d0b71938879f6337cc6e078696a8f618d9a10 (diff)
downloadaports-96d355a76e7b7cdb9a76090bbe8ef57118149d60.tar.gz
aports-96d355a76e7b7cdb9a76090bbe8ef57118149d60.tar.bz2
aports-96d355a76e7b7cdb9a76090bbe8ef57118149d60.tar.xz
main/libinput: move quirks and udev rules to -libs subpkg
These files are required for any device which may differ from vendor to vendor, e.g. trackpads
-rw-r--r--main/libinput/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/libinput/APKBUILD b/main/libinput/APKBUILD
index 62c5ab38169..a1ea1ffd0fe 100644
--- a/main/libinput/APKBUILD
+++ b/main/libinput/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=libinput
pkgver=1.15.5
-pkgrel=0
+pkgrel=1
pkgdesc="Library for handling input devices"
url="https://www.freedesktop.org/wiki/Software/libinput"
arch="all"
@@ -39,6 +39,14 @@ package() {
DESTDIR="$pkgdir" ninja -C builddir/ install
}
+libs() {
+ default_libs
+
+ mv "$pkgdir"/usr/lib/udev "$subpkgdir"/usr/lib
+ mkdir -p "$subpkgdir"/usr/share/
+ mv "$pkgdir"/usr/share/libinput "$subpkgdir"/usr/share
+}
+
zshcomp() {
depends=""
pkgdesc="Zsh completions for $pkgname"