aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author6543 <6543@obermui.de>2022-05-15 03:01:41 +0200
committer6543 <6543@obermui.de>2022-05-15 03:01:41 +0200
commit9834c5ba886806dbc09c6eb85ef353c13e55d94b (patch)
tree0ccda2571d741e284ce61bdc1b310b8ab955a872
parent7daf7dfd60ea1378a1784ea82a56b183702b2e72 (diff)
community/gitea: upgrade to v1.16.7
-rw-r--r--community/gitea/APKBUILD9
-rw-r--r--community/gitea/gitea.initd25
2 files changed, 15 insertions, 19 deletions
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 2d4612ec034..4c67dad4259 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Contributor: 6543 <6543@obermui.de>
+# Contributor: techknowlogick <techknowlogick@gitea.io>
# Maintainer: 6543 <6543@obermui.de>
pkgname=gitea
-pkgver=1.16.5
-pkgrel=2
+pkgver=1.16.7
+pkgrel=0
pkgdesc="A self-hosted Git service written in Go"
url="https://gitea.io"
# armhf: failing tests
@@ -119,8 +120,8 @@ package() {
}
sha512sums="
-3c367155a97809d587879b023979ad198106040c362e6d5e6df26cad384c614aaac1c47d84bcac0177a5b5546c4a76e95cfff9cf76b411226c0b1aa618d4d4b3 gitea-1.16.5.tar.gz
-207129e9f304b0db77a334e13aab5f9d3b0184af0fa3d63baac7eac5309210afe2b05e91386346a383131004af518fe308c63c49c2429ab85b1fd7ba783a6426 gitea.initd
+7a31330e46078e215eecfbb2ec28373be1a176790720afbcf9674f3530d66f300d8ef9e47b9b9124cda9ce585d26d40c975e4897e5a3477dcec28b6f2b16735c gitea-1.16.7.tar.gz
+f859f46204fef596344fda53af7e945baca8639fd2839e90f2b4a8e361a2c77490be18473469cb40cb362671f5b2604e6ea18955dc0e56f44346ffaf2a838a91 gitea.initd
431184faffa8996873d92d7b0d16bc4b1a0178d264cd2928d1f49b13ad3e6470d9ede7a18c12112deeeb38f0647ccc0b012e98bcbd96e7b8496a3dc18f5b1fb7 gitea.ini
b16eb5d89a301c796046ebcb726015872f122756a324802f042d4cb8ec17d41ce0fa684e17c26ade265273984e2b621d579e929cb63ed7dbc12774257bd13e9f fix-tests-ssh-hostkeys.patch
"
diff --git a/community/gitea/gitea.initd b/community/gitea/gitea.initd
index 78903396c74..b71b00b3b37 100644
--- a/community/gitea/gitea.initd
+++ b/community/gitea/gitea.initd
@@ -7,22 +7,17 @@ command_user="${GITEA_USER:-gitea}"
command_args="web --config '${GITEA_CONF:-/etc/gitea/app.ini}'"
supervise_daemon_args="--env GITEA_WORK_DIR='${GITEA_WORK_DIR:-/var/lib/gitea}' --chdir '${GITEA_WORK_DIR:-/var/lib/gitea}' --stdout '${GITEA_LOG_FILE:-/var/log/gitea/http.log}' --stderr '${GITEA_LOG_FILE:-/var/log/gitea/http.log}'"
pidfile="/run/gitea.pid"
-extra_started_commands="reload"
+#extra_started_commands="reload"
depend() {
- use logger dns
- need net
- after firewall mysql postgresql
+ use logger dns
+ need net
+ after firewall mysql postgresql
}
-stop() {
- ebegin "Stopping ${RC_SVCNAME}"
- start-stop-daemon --signal INT --pidfile "${pidfile}"
- eend $? "Failed to stop ${RC_SVCNAME}"
-}
-
-reload() {
- ebegin "Reloading ${RC_SVCNAME}"
- start-stop-daemon --signal HUP --pidfile "${pidfile}"
- eend $?
-}
+#https://github.com/go-gitea/gitea/issues/17976
+#reload() {
+# ebegin "Reloading ${RC_SVCNAME}"
+# ${supervisor} ${RC_SVCNAME} --signal HUP --pidfile "${pidfile}"
+# eend $?
+#}