aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-11-10 14:07:42 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2021-11-10 14:07:42 +0100
commit98a5816f2bfd82fb743a434d7919533cf995d770 (patch)
tree4ac31f2b1ab1806e6ce1fcef65e341188e16faa2
parenteb864f49c45558749602099244565cb4e5e93499 (diff)
downloadaports-98a5816f2bfd82fb743a434d7919533cf995d770.tar.gz
aports-98a5816f2bfd82fb743a434d7919533cf995d770.tar.bz2
aports-98a5816f2bfd82fb743a434d7919533cf995d770.tar.xz
community/lirc: fix recursive dependency
lirc-python needs lirc for the following symlink: usr/lib/python3.9/site-packages/lirc-setup/configs -> ../../../../share/lirc/configs lirc itself needs lirc-python for: usr/bin/lirc-setup -> ../lib/python3.9/site-packages/lirc-setup/lirc-setup This creates a recursive dependency. An easy way to solve this right now seems to be moving lirc-setup to the lirc-python subpackage. Since the lirc-setup script actually uses stuff from the Python library. See #13173
-rw-r--r--community/lirc/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/lirc/APKBUILD b/community/lirc/APKBUILD
index 8462b087d9d..9a950676c3c 100644
--- a/community/lirc/APKBUILD
+++ b/community/lirc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Cian Hughes <Ci@nHugh.es>
pkgname=lirc
pkgver=0.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Infrared signal receiver and sender"
options="!check" # no tests
arch="all"
@@ -41,7 +41,12 @@ package() {
python() {
pkgdesc="Python3 bindings for lirc"
depends=""
+
amove usr/lib/python3*
+
+ # This is a symlink to ../lib/python3.9/site-packages/lirc-setup/lirc-setup
+ # if we don't move this symlink to the subpackage we have a recursive dep.
+ amove usr/bin/lirc-setup
}
sha512sums="33d9bd55bccf726ea39625f124d429cd13b64a8427b890a6210752c6307727439b25a04f00d8d26aee84003ed9e2eeb259da81a7d26913f1aa7210fd1fa26a55 lirc-0.10.1.tar.gz