aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-05-12 01:53:39 +0000
committeralice <alice@ayaya.dev>2022-05-12 02:09:47 +0000
commit98fd96a856192ac84b558c0631f34261571b2463 (patch)
treed43670da57b5a7a9a6aa3f43f68626c4b6bcf382
parentbfadff337df88a22983dcc686751a2d6d94a459a (diff)
downloadaports-98fd96a856192ac84b558c0631f34261571b2463.tar.gz
aports-98fd96a856192ac84b558c0631f34261571b2463.tar.bz2
aports-98fd96a856192ac84b558c0631f34261571b2463.tar.xz
community/gdnsd: upgrade to 3.8.0
-rw-r--r--community/gdnsd/APKBUILD35
-rw-r--r--community/gdnsd/dclists.patch32
-rwxr-xr-xcommunity/gdnsd/gdnsd.initd50
3 files changed, 76 insertions, 41 deletions
diff --git a/community/gdnsd/APKBUILD b/community/gdnsd/APKBUILD
index 3ed31eb9e33..6558cca1702 100644
--- a/community/gdnsd/APKBUILD
+++ b/community/gdnsd/APKBUILD
@@ -1,18 +1,38 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=gdnsd
-pkgver=2.4.3
+pkgver=3.8.0
pkgrel=0
pkgdesc="Geographic Authoritative DNS server"
-url="https://github.com/blblack/gdnsd/"
+url="https://github.com/gdnsd/gdnsd/"
arch="all"
license="GPL-3.0-or-later"
-makedepends="userspace-rcu-dev libev-dev libcap-dev libmaxminddb-dev ragel autoconf automake libtool"
-checkdepends="perl perl-libwww perl-socket6 perl-io-socket-inet6 perl-http-daemon perl-test-harness perl-test-harness-utils"
+makedepends="
+ autoconf
+ automake
+ libcap-dev
+ libev-dev
+ libmaxminddb-dev
+ libsodium-dev
+ libtool
+ ragel
+ userspace-rcu-dev
+ "
+checkdepends="
+ perl
+ perl-libwww
+ perl-socket6
+ perl-io-socket-inet6
+ perl-http-daemon
+ perl-test-harness
+ perl-test-harness-utils
+ "
install="$pkgname.pre-install"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-doc $pkgname-openrc"
source="https://github.com/gdnsd/gdnsd/releases/download/v$pkgver/gdnsd-$pkgver.tar.xz
+ dclists.patch
gdnsd.initd"
+options="!check" # missing perl modules for tests
# secfixes:
# 2.4.3-r0:
@@ -44,6 +64,7 @@ package() {
}
sha512sums="
-b9a53c3d003880822ebe257a83a13c61cb8c5e1f7c0a0116cf6cbdc505b759e8d28e19b1d7029a0fcc3c93997255fb8a12cb70715f0628392682840f03cc47d2 gdnsd-2.4.3.tar.xz
-27b6ed95452072ddbf767c87202bde8f70fb5272395a599ad6fec1bd5d0eaf1cefc217abf08531e5e0c0d7846018e31ffd215c0f8e92b151fc0e419cdc81e3f1 gdnsd.initd
+165c5576b1142a873dcd54b42f1b58a3ecd1958b274eb5e3c09fbd918b5851f554213605b062dea966cc7502d6e91ec79e32c121aba23ea4e560db6b488106af gdnsd-3.8.0.tar.xz
+ad1519c076e0f8b55ce9e202790cf64b1ab81f10b1c770fcd050acc96ad7d99a0be1bd7bd0791de3d920e1a85993131f9638934567792a060b8dfe52f7e00bea dclists.patch
+7e66f9d3dab3a36334d47740f12ee7f3ffd363d416bd1fcca4b339db8ba858419555751786247ffc4e5faf68c6b5fa87b84c04ffa25133a17b186bdf83c365b9 gdnsd.initd
"
diff --git a/community/gdnsd/dclists.patch b/community/gdnsd/dclists.patch
new file mode 100644
index 00000000000..9390d094adb
--- /dev/null
+++ b/community/gdnsd/dclists.patch
@@ -0,0 +1,32 @@
+--- a/libgdmaps/dclists.c
++++ b/libgdmaps/dclists.c
+@@ -60,13 +60,6 @@
+ // used on true shutdown of the whole gdmap (only debug
+ // mode for the real plugin).
+
+-struct dclists {
+- unsigned count; // count of unique result lists
+- unsigned old_count; // count from object we cloned from
+- uint8_t** list; // strings of dc numbers
+- const dcinfo_t* info; // dclists_t doesn't own "info", just uses it for reference a lot
+-};
+-
+ dclists_t* dclists_new(const dcinfo_t* info)
+ {
+ const unsigned num_dcs = dcinfo_get_count(info);
+--- a/libgdmaps/dclists.h
++++ b/libgdmaps/dclists.h
+@@ -28,6 +28,13 @@
+ #include <inttypes.h>
+ #include <stdbool.h>
+
++struct dclists {
++ unsigned count; // count of unique result lists
++ unsigned old_count; // count from object we cloned from
++ uint8_t** list; // strings of dc numbers
++ const dcinfo_t* info; // dclists_t doesn't own "info", just uses it for reference a lot
++};
++
+ typedef struct dclists dclists_t;
+
+ typedef enum {
diff --git a/community/gdnsd/gdnsd.initd b/community/gdnsd/gdnsd.initd
index e8a75e846b8..fc9028cebde 100755
--- a/community/gdnsd/gdnsd.initd
+++ b/community/gdnsd/gdnsd.initd
@@ -1,20 +1,15 @@
#!/sbin/openrc-run
name="gdnsd daemon"
-extra_commands="configtest"
-extra_started_commands="reload fastrestart"
+extra_commands="checkconf"
+extra_started_commands="reload"
description="Geographic Authoritative DNS server"
-description_configtest="Run syntax tests for configuration files only."
-description_reload="Signal running gdnsd to reload configuration files"
-description_fastrestart="Optimized restart sequence (minimizes down time)"
-
-if [ -z "${GDNSD_CONFFILE}" ]; then
- if [ "${SVCNAME}" = "gdnsd" ]; then
- GDNSD_ROOT=system
- else
- GDNSD_ROOT=/var/gdnsd/${SVCNAME}
- fi
-fi
+description_configtest="Run syntax tests for configuration files only"
+description_reload="Reload zone data"
+command_background=true
+pidfile=/var/run/${RC_SVCNAME}.pid
+command="/usr/sbin/gdnsd"
+command_args="start"
depend() {
need net
@@ -23,31 +18,18 @@ depend() {
provide auth-dns
}
-act() {
- ebegin "$1 ${SVCNAME}"
- /usr/sbin/gdnsd -d ${GDNSD_ROOT} $2
+checkconf() {
+ ebegin "Checking configuration of ${RC_SVCNAME}"
+ gdnsd checkconf
eend $?
}
-configtest() {
- act "Checking configuration" checkconf
-}
-
-start() {
- act "Starting" start
-}
-
-stop () {
- if [ "${RC_CMD}" = "restart" ]; then
- configtest || return 1
- fi
- act "Stopping" stop
-}
-
-fastrestart() {
- act "Restarting" restart
+stop_pre() {
+ checkconf
}
reload() {
- act "Reloading" reload
+ ebegin "Reloading ${RC_SVCNAME} zone data"
+ gdnsdctl reload-zones
+ eend $?
}