aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-06-18 08:38:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-06-18 08:40:37 +0000
commit9a555c83e0805dde947d48830161b5c52988c7e0 (patch)
tree616ef95585448e5c267ab7876a3c0bfa9e7922d2
parent72a355e1c8437c4e32a3e22bc3888905a6e545ba (diff)
main/ca-certificates: don't delete ca-certificates.crt
The ca-certificates.crt was previously not shipped with any package, but generated from trigger script, so the post-deinstall needed to delete it. Since commit 7363758e1d81 (main/ca-certificates: ditch python dep, symlink ca-certificates.crt) this is no longer the case, and we ship a pre-generated bundle in the ca-certificates-bundle subpackage. So we should no longer delte ca-certificates.crt from post-deinstall. fixes #11663
-rw-r--r--main/ca-certificates/APKBUILD2
-rw-r--r--main/ca-certificates/ca-certificates.post-deinstall5
2 files changed, 3 insertions, 4 deletions
diff --git a/main/ca-certificates/APKBUILD b/main/ca-certificates/APKBUILD
index 7560bb22f7b..4b9e93adaae 100644
--- a/main/ca-certificates/APKBUILD
+++ b/main/ca-certificates/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ca-certificates
pkgver=20191127
-pkgrel=3
+pkgrel=4
pkgdesc="Common CA certificates PEM files from Mozilla"
url="https://www.mozilla.org/en-US/about/governance/policies/security-group/certs/"
arch="all"
diff --git a/main/ca-certificates/ca-certificates.post-deinstall b/main/ca-certificates/ca-certificates.post-deinstall
index ead634716c2..10d219f03f5 100644
--- a/main/ca-certificates/ca-certificates.post-deinstall
+++ b/main/ca-certificates/ca-certificates.post-deinstall
@@ -1,7 +1,6 @@
#!/bin/sh
-# clean up broken symlinks and ca-certificates.crt store
-find -L /etc/ssl/certs -maxdepth 1 \( -type l -o -name ca-certificates.crt \) \
- -delete
+# clean up broken symlinks store
+find -L /etc/ssl/certs -maxdepth 1 -type l -delete
rmdir /etc/ssl/certs 2>/dev/null || true