aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBradford D. Boyle <bradford.d.boyle@gmail.com>2021-01-12 21:44:04 -0800
committerLeo <thinkabit.ukim@gmail.com>2021-01-14 03:01:06 +0000
commit9a6b65561a0529b6ecf87bdff24567054283f348 (patch)
tree67086fc3d0e484939f2acdf4e282c14f42304428
parent3c179858dc589cdf4bbeb6e4e3eca64eb950644a (diff)
testing/hamlib: upgrade to 4.0
- update source location to GitHub - enable python3 bindings
-rw-r--r--testing/hamlib/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/testing/hamlib/APKBUILD b/testing/hamlib/APKBUILD
index f50a5d16ff2..32011598430 100644
--- a/testing/hamlib/APKBUILD
+++ b/testing/hamlib/APKBUILD
@@ -1,22 +1,23 @@
# Contributor: Bradford D. Boyle <bradford.d.boyle@gmail.com>
# Maintainer: Bradford D. Boyle <bradford.d.boyle@gmail.com>
pkgname=hamlib
-pkgver=3.3
-pkgrel=2
+pkgver=4.0
+pkgrel=0
pkgdesc="Library to control radio transceivers and receivers"
-url="http://www.hamlib.org/"
+url="https://hamlib.github.io/"
arch="all"
license="LGPL-2.0-or-later"
-makedepends="linux-headers perl-dev swig tcl-dev chrpath libusb-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-perl $pkgname-tcl"
-source="https://downloads.sourceforge.net/project/hamlib/hamlib/$pkgver/hamlib-$pkgver.tar.gz"
+makedepends="linux-headers perl-dev python3-dev swig tcl-dev chrpath libusb-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-perl py3-$pkgname:py3 $pkgname-tcl"
+source="https://github.com/Hamlib/Hamlib/releases/download/$pkgver/hamlib-$pkgver.tar.gz"
build() {
./configure \
+ PYTHON=/usr/bin/python3 \
--prefix=/usr \
--sbindir=/usr/bin \
--with-perl-binding \
- --without-python-binding \
+ --with-python-binding \
--with-tcl-binding
make
}
@@ -44,9 +45,16 @@ perl() {
chrpath --delete "$subpkgdir"/usr/lib/perl5/site_perl/current/auto/Hamlib/Hamlib.so
}
+py3() {
+ pkgdesc="Python3 bindings for $pkgname"
+ depends="python3"
+
+ amove usr/lib/python3*
+}
+
tcl() {
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/tcl8.6 "$subpkgdir"/usr/lib/
}
-sha512sums="4cf6c94d0238c8a13aed09413b3f4a027c8ded07f8840cdb2b9d38b39b6395a4a88a8105257015345f6de0658ab8c60292d11a9de3e16a493e153637af630a80 hamlib-3.3.tar.gz"
+sha512sums="6c097f503d1050dca4e5ab9091cd9885f8db8b0e4b2fb26af570f1871f2da713ac3fe10e3629d20ebfc2927768555ad277e68cc38821f4a905900b8d3a5ba8c9 hamlib-4.0.tar.gz"