aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Liske <thomas@fiasko-nw.net>2020-08-08 19:02:21 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-11 04:47:14 +0000
commit9b37a491930887ff711f8cbee9b08506a626de6a (patch)
treed012040c4bf807d9a289dbeaf54564405bc11435
parentfe7af3c40bec24b908362f412423da21d3460d02 (diff)
community/anytun: use checkpath in initd to create non-public files
-rw-r--r--community/anytun/APKBUILD4
-rw-r--r--community/anytun/anytun.initd3
2 files changed, 3 insertions, 4 deletions
diff --git a/community/anytun/APKBUILD b/community/anytun/APKBUILD
index 4024f02f695..b72a4d9cd1c 100644
--- a/community/anytun/APKBUILD
+++ b/community/anytun/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=anytun
pkgver=0.3.8
-pkgrel=0
+pkgrel=1
pkgdesc="Secure anycast tunneling protocol implementation for flexible and fault-tolerant VPNs"
options="!check" # No testsuite
url="https://www.anytun.org/"
@@ -35,4 +35,4 @@ package() {
sha512sums="c1631983c0f1d735792ae1775aedb87241ae94ccd9cda12885790ecb09e0279518d3414c41945f385b2b30ad20db6a4c68fc526d7d6f777f2929c0d23174f699 anytun-0.3.8.tar.gz
8c2eece0357666867f8cd9c7ef9307bcf88b9172ac033c18bd33ba470b3c19ad722c7eeafcda3a9ae95539d86ab04285fe5d7fa9766630f689c58e2c3fb239c3 fix-iostream.patch
-a31455058e0ac60ed9457c79eea789ce19ba49abc200b59c0d8390eb0c3b6f09813177f9b679fb8ac69ac7b0be862e4604d19298ae4cd79925511fff3963e93d anytun.initd"
+8ca2691139ed42474fa9d2e81e8c43ae6ec48c61d07055e6436cddb6d43521a735e315ce1e99d7ef253e8d15515416df92db51fd77e7e13f6c58c820fb9d0ffb anytun.initd"
diff --git a/community/anytun/anytun.initd b/community/anytun/anytun.initd
index 0767a738020..d831feb3486 100644
--- a/community/anytun/anytun.initd
+++ b/community/anytun/anytun.initd
@@ -56,8 +56,7 @@ stop_vpn () {
start_configd () {
if [ -d $CONFIG_DIR/$NAME/conf.d ] ; then
- test -d $VARCONFIG_DIR || mkdir -p $VARCONFIG_DIR
- chmod 700 $VARCONFIG_DIR
+ test -d $VARCONFIG_DIR && chmod 700 $VARCONFIG_DIR || checkpath -d -m 0700 $VARCONFIG_DIR
rm -f $VARCONFIG_DIR/$NAME 2>/dev/null
KDPRF=`sed 's/#.*//' < $CONFIG_DIR/$NAME/config | grep -e 'kd-prf' | sed 's/^/ --/' | xargs echo`
for CLIENTPATH in $CONFIG_DIR/$NAME/conf.d/* ; do