aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-04-20 08:02:32 +0000
committerpsykose <alice@ayaya.dev>2023-04-20 10:02:32 +0200
commit9b8139fdbb92d0e2c91e75c1c2290cc221633bb5 (patch)
tree398d037d63784fbbfb830f6cfb82615c187f0043
parentc1c5bf1538289dc12a25a77dd64497213625d161 (diff)
community/gcc6: fix build?
for some reason the first val gets replaced by val_gmp.h later..
-rw-r--r--community/gcc6/APKBUILD2
-rw-r--r--community/gcc6/isl-0.22.patch3
2 files changed, 3 insertions, 2 deletions
diff --git a/community/gcc6/APKBUILD b/community/gcc6/APKBUILD
index 40a44da60f9..30d2962d9e5 100644
--- a/community/gcc6/APKBUILD
+++ b/community/gcc6/APKBUILD
@@ -362,6 +362,6 @@ f4ef08454e28c8732db69115e4998ec153399e8d229dd27f923dbdcf57b68128a65640d026cc7f45
86be3338cc9c33089608bc4c5e3b7918c4e500a345c338f361b18c342119a6ed69af5495d72950de7106d760f003528b46ad14795e805f8a3331e206dcb234e3 gcc-pure64-mips.patch
aae9d510326bed6eca0b1f680d2caf64dd804e73fb9d726c8932faa845c07e1be6ab12920972d8fb80a33dafedcaafca71487b0eaf10e6d5fa7deb853926b933 fix-ppc64le-coercion-r261621.patch
0e20a5717c20ddc1d9f00276453b0abb4868adff0496604ad7d5b766a1028181c09c2061c5648bcfd4cb29dca7048cc866d2f27c013d82c2440164f17eac685d 0017-pr93402.patch
-8c46436ca6ff75d68186e6aeeb16addee7bf2502c4295b86f71ab3dc9d58540cc5cf8723bee69b3aeae07cde0c725a19fbe69c1110a23549331b5b0b250fd31f isl-0.22.patch
+c1724cdbb1d1387521d2dc694bd51ea1d89948bd1b89e5ac56b39d2c5aa878e98143619086eded75fefbfb8cc93fc06a5c5f6f9e2cb2af915ea37c3b89ace919 isl-0.22.patch
5c47cad86c42048c4857ad087d5272b3f7c3306dbb4cba4bdad15c10109944cda88e8f51318726bcf5df0c511cab1751df238cfbce225c910485f04ce1cfec76 musl-1.2.3.patch
"
diff --git a/community/gcc6/isl-0.22.patch b/community/gcc6/isl-0.22.patch
index 7fe5693c471..5ada1596dec 100644
--- a/community/gcc6/isl-0.22.patch
+++ b/community/gcc6/isl-0.22.patch
@@ -16,12 +16,13 @@ diff --git a/gcc/graphite.h b/gcc/graphite.h
index be0a22b38942..8db5700e03f1 100644
--- a/gcc/graphite.h
+++ b/gcc/graphite.h
-@@ -26,6 +26,8 @@ along with GCC; see the file COPYING3. If not see
+@@ -26,6 +26,9 @@ along with GCC; see the file COPYING3. If not see
#include <isl/options.h>
#include <isl/ctx.h>
#include <isl/val.h>
+#include <isl/id.h>
+#include <isl/space.h>
++#include <isl/val.h>
#include <isl/set.h>
#include <isl/union_set.h>
#include <isl/map.h>