aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-11-04 16:42:58 +0100
committerBart Ribbers <bribbers@disroot.org>2021-11-04 16:44:46 +0100
commit9d0f86869272ed2eb1f6d027a194250d8c75b431 (patch)
treeb1d2130ddb80cc8f0b87620ec029b4f535d1efc1
parent576c7df044405356531e1f9b16e668c3fa438b9b (diff)
downloadaports-9d0f86869272ed2eb1f6d027a194250d8c75b431.tar.gz
aports-9d0f86869272ed2eb1f6d027a194250d8c75b431.tar.bz2
aports-9d0f86869272ed2eb1f6d027a194250d8c75b431.tar.xz
main/jack: increase API version
This way it'll always be preferred by apk over pipewire-jack unless the user has explicitly told apk to install pipewire-jack
-rw-r--r--main/jack/APKBUILD11
-rw-r--r--main/jack/increase-api-version.patch16
2 files changed, 22 insertions, 5 deletions
diff --git a/main/jack/APKBUILD b/main/jack/APKBUILD
index 908879833c..7e69d561f1 100644
--- a/main/jack/APKBUILD
+++ b/main/jack/APKBUILD
@@ -1,8 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=jack
-_realname=jack2
pkgver=1.9.19
-pkgrel=1
+pkgrel=2
pkgdesc="The Jack Audio Connection Kit"
url="https://www.jackaudio.org/"
arch="all"
@@ -10,10 +9,11 @@ license="GPL-2.0 GPL-2.0-or-later LGPL-2.0-or-later"
makedepends="$depends_dev alsa-lib-dev dbus-dev expat-dev libsamplerate-dev
libsndfile-dev ncurses-dev readline-dev python3 linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbus $pkgname-example-clients:_clients"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jackaudio/jack2/archive/v$pkgver.tar.gz
+source="https://github.com/jackaudio/jack2/archive/v$pkgver/jack2-v$pkgver.tar.gz
fix-execinfo.patch
+ increase-api-version.patch
"
-builddir="$srcdir"/$_realname-$pkgver
+builddir="$srcdir/jack2-$pkgver"
options="!check" # no real tests provided
prepare() {
@@ -51,6 +51,7 @@ _clients() {
}
sha512sums="
-d8d5fe17e2984959546af3c53f044aa4648860e19ff8ffd54452e87fa6cdfd111f825c57e3df17cb8ed95de8392b6f354b12ded41e3e021a37f07b99a89ba18d jack-1.9.19.tar.gz
+d8d5fe17e2984959546af3c53f044aa4648860e19ff8ffd54452e87fa6cdfd111f825c57e3df17cb8ed95de8392b6f354b12ded41e3e021a37f07b99a89ba18d jack2-v1.9.19.tar.gz
b5abec7e67485d1c13f399b5961539177dd35d21c5dd95e0aa767adb0f5b1e588e9ca2f9b29cc4d66fc039311ff7eacc4cf21f6700ef0a2c8de99b63cb00f84d fix-execinfo.patch
+d187d6a5e4e5c748d4f5eccf66a76249a4eb7135c22e32ca40eb2ea806ec6877074d8ba91c9cc106ae8e62ada6afda248fa48ebb147c720576ab092904993f51 increase-api-version.patch
"
diff --git a/main/jack/increase-api-version.patch b/main/jack/increase-api-version.patch
new file mode 100644
index 0000000000..78b07efe55
--- /dev/null
+++ b/main/jack/increase-api-version.patch
@@ -0,0 +1,16 @@
+jack's low API version (so:libjack.so.0.1.0) makes apk prefer pipewire-jack over jack
+We don't want this, users need to explicitly tell users they prefer pipewire-jack, so we increase the API version here to be always higher than pipewire-jack
+
+diff --git a/wscript b/wscript
+index e0d32c8d..2c0a7123 100644
+--- a/wscript
++++ b/wscript
+@@ -13,7 +13,7 @@ from waflib.Build import BuildContext, CleanContext, InstallContext, UninstallCo
+
+ VERSION='1.9.20'
+ APPNAME='jack'
+-JACK_API_VERSION = '0.1.0'
++JACK_API_VERSION = '0.999.0'
+
+ # these variables are mandatory ('/' are converted automatically)
+ top = '.'