aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 19:25:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 20:01:09 -0300
commit9da8ea74acce1e2eac5f1f4530856d9cc1bce52f (patch)
tree5574c100871ea2e641556e322ea6d8bee0bcf7be
parent315d1e147d063cc5bf7b67025a9a9aafbc7b9ada (diff)
community/notmuch: drop python2
-rw-r--r--community/notmuch/APKBUILD34
1 files changed, 9 insertions, 25 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index a31dbb7c87c..6a9fb4b477d 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -3,32 +3,27 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.28
-pkgrel=1
+pkgrel=2
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
license="GPL-3.0"
-makedepends="gzip xapian-core-dev gmime-dev talloc-dev py-sphinx
- py-requests python2-dev python3-dev bash-completion"
+makedepends="gzip xapian-core-dev gmime-dev talloc-dev py3-sphinx
+ py3-requests python3-dev bash-completion"
checkdepends="sed coreutils diffutils bash tar mdocml grep perl"
subpackages="
- py2-$pkgname:py2
py3-$pkgname:py3
$pkgname-dev
- $pkgname-doc
$pkgname-libs
$pkgname-emacs:emacs:noarch
$pkgname-vim:vim:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
-source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
+source="https://notmuchmail.org/releases/notmuch-$pkgver.tar.gz
fix-tests.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
-
PYTHON=python3 ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -41,7 +36,6 @@ build() {
make PREFIX=/usr DESTDIR="$pkgdir"
cd "$builddir"/bindings/python
- python2 setup.py build
python3 setup.py build
}
@@ -68,7 +62,7 @@ check() {
T150-tagging|T060-count|T070-insert|T357-index-decryption) continue ;;
esac
- ./${test}
+ ./$test
done
}
@@ -113,22 +107,12 @@ zshcomp() {
rm -rf "$pkgdir"/usr/share/zsh
}
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+py3() {
+ pkgdesc="$pkgdesc (for python3)"
+ depends="$depends python3"
cd "$builddir"/bindings/python
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-py2() {
- _py python2
-}
-
-py3() {
- _py python3
+ python3 setup.py install --prefix=/usr --root="$subpkgdir"
}
sha512sums="56c8e6b742990b5b1d5b8d12146cc9eb710c6b216c876fd3824cc88b9051fef8251f53809ba39cd2f0fbd5e4ccee9ddedc7a602e3584d8a158abe4f2a094242f notmuch-0.28.tar.gz