aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrigory Kirillov <txgk@bk.ru>2022-08-11 13:01:10 +0300
committeralice <alice@ayaya.dev>2022-08-11 13:54:11 +0000
commit9dfa4d49ef41199189987dc45d8c5ab7a8d4b046 (patch)
treea70e8daee447a176800bf3452d3f4b142cfda356
parentdbbc1f364ca2ca75b67f8974b70c6b6f9b3cf044 (diff)
testing/fheroes2: use GNU iconv to generate .mo files
-rw-r--r--testing/fheroes2/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/testing/fheroes2/APKBUILD b/testing/fheroes2/APKBUILD
index e4b370deeac..eba2cf70411 100644
--- a/testing/fheroes2/APKBUILD
+++ b/testing/fheroes2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grigory Kirillov <txgk@bk.ru>
pkgname=fheroes2
pkgver=0.9.18
-pkgrel=0
+pkgrel=1
pkgdesc="Recreation of HoMM2 game engine"
url="https://github.com/ihhub/fheroes2"
arch="all"
@@ -10,6 +10,8 @@ license="GPL-2.0-only"
options="!check" # no test suite
makedepends="
gettext
+ gnu-libiconv
+ sed
sdl2-dev
sdl2_image-dev
sdl2_mixer-dev
@@ -25,16 +27,9 @@ langdir="/usr/share/$pkgname/files/lang"
build() {
make FHEROES2_WITH_IMAGE=1 FHEROES2_DATA=/usr/share/fheroes2
- # hu lt nl tr:
- # these languages require iconv TRANSLIT extension to be built (musl doesn't support that)
- # ro:
- # just fails to build because "ISO-8859-16" charset is not portable
- # fr:
- # yields lots of "invalid multibyte sequence" messages and errors out
- # make: *** [Makefile:33: fr.mo] Error 1
- for lang in hu lt nl tr ro fr; do
- rm files/lang/$lang.po
- done
+ # Use GNU iconv instead of musl-based one, because this project uses
+ # TRANSLIT iconv extension which is not present in musl implementation.
+ sed -i s/iconv/gnu-iconv/g files/lang/Makefile
make -C files/lang
}