aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-08-14 03:34:29 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-14 01:47:02 +0000
commit9e2a9f734590e05aa3950789bf3f4f8b2e7528a8 (patch)
tree68ad7cc843d55c641d8eb3c6909a33bd218baba0
parentb76182ad4e4020112ffe0fdafe8996fb42c9592a (diff)
community/swayidle: use default shell completion functions
-rw-r--r--community/swayidle/APKBUILD35
1 files changed, 5 insertions, 30 deletions
diff --git a/community/swayidle/APKBUILD b/community/swayidle/APKBUILD
index 26f2abff8fb..6e2064f8992 100644
--- a/community/swayidle/APKBUILD
+++ b/community/swayidle/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=swayidle
pkgver=1.6
-pkgrel=2
+pkgrel=3
pkgdesc="Idle management daemon for Wayland"
url="https://swaywm.org"
arch="all"
@@ -18,9 +18,9 @@ makedepends="
"
subpackages="
$pkgname-doc
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-fish-completion:fishcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
"
source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/swayidle/archive/$pkgver.tar.gz"
@@ -34,33 +34,8 @@ build() {
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share/
-}
-
-fishcomp() {
- depends=""
- pkgdesc="Fish completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel fish"
-
- mkdir -p "$subpkgdir"/usr/share/fish
- mv "$pkgdir"/usr/share/fish/vendor_completions.d "$subpkgdir"/usr/share/fish/completions
-}
-
-zshcomp() {
- depends=""
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
- mkdir -p "$subpkgdir"/usr/share/zsh
- mv "$pkgdir"/usr/share/zsh/site-functions "$subpkgdir"/usr/share/zsh
+ mv "$pkgdir"/usr/share/fish/vendor_completions.d "$pkgdir"/usr/share/fish/completions
}
sha512sums="c82b0d2aee06f87fd71e9e2208e917c0dc7afe80ab0b782c3165127519445021d8cf363292eee99f939165eb813909f2a4ee74153e776557c6d06672de2c1c82 swayidle-1.6.tar.gz"