aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-06-21 16:38:47 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-21 17:16:15 +0000
commit9e93b8ef8bd2f928b3293afae8af307aab17832b (patch)
treec6fe407c1777ca592b97c63543a6cd1500544f49
parent71c18a0a685670379cdd93d2b4f8382c1800537b (diff)
downloadaports-9e93b8ef8bd2f928b3293afae8af307aab17832b.tar.gz
aports-9e93b8ef8bd2f928b3293afae8af307aab17832b.tar.bz2
aports-9e93b8ef8bd2f928b3293afae8af307aab17832b.tar.xz
community/vidstab: move from testing
-rw-r--r--community/vidstab/APKBUILD (renamed from testing/vidstab/APKBUILD)14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/vidstab/APKBUILD b/community/vidstab/APKBUILD
index 2b62075cf8a..c68d48bf2cb 100644
--- a/testing/vidstab/APKBUILD
+++ b/community/vidstab/APKBUILD
@@ -1,7 +1,6 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=vidstab
-_pkgname=vid.stab
pkgver=1.1.0
pkgrel=1
arch="all"
@@ -9,25 +8,26 @@ url="http://public.hronopik.de/vid.stab/"
pkgdesc="Video stabilization library"
license="GPL-2.0-or-later"
makedepends="cmake"
-source="$pkgname-$pkgver.tar.gz::https://github.com/georgmartius/vid.stab/archive/v$pkgver.tar.gz"
+source="https://github.com/georgmartius/vid.stab/archive/v$pkgver/vid.stab-v$pkgver.tar.gz"
subpackages="$pkgname-dev"
options="!check" # No tests
-builddir="$srcdir/$_pkgname-$pkgver"
+builddir="$srcdir/vid.stab-$pkgver"
build() {
- cmake \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
check() {
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
-sha512sums="e82a4b6dd854b8415952cc0a8bdea06c01ff40a497c8e98177831e29031ec535b9f47cc30d5444c47bfd91871615a1662e3991185e9eb179acf37ea601073cdf vidstab-1.1.0.tar.gz"
+sha512sums="e82a4b6dd854b8415952cc0a8bdea06c01ff40a497c8e98177831e29031ec535b9f47cc30d5444c47bfd91871615a1662e3991185e9eb179acf37ea601073cdf vid.stab-v1.1.0.tar.gz"