aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuss Webber <russ@rw.id.au>2019-05-07 15:17:15 +1000
committerTBK <tbk@jjtc.eu>2019-05-29 22:23:47 +0200
commit9f454b6636599c08743ecb66eed86e79659b43df (patch)
tree7ebde125645205f352615dfd4674f7ad2776ccbc
parent56016bd47609d9f858a98525fabe65617eebf9ed (diff)
testing/py3-catkin-pkg-modules: new aport
http://wiki.ros.org/catkin_pkg Standalone Python library for the catkin build system. Closes: GH-7641
-rw-r--r--testing/py3-catkin-pkg-modules/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/py3-catkin-pkg-modules/APKBUILD b/testing/py3-catkin-pkg-modules/APKBUILD
new file mode 100644
index 00000000000..cebf6cc77af
--- /dev/null
+++ b/testing/py3-catkin-pkg-modules/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Russ Webber <russ@rw.id.au>
+# Maintainer: Russ Webber <russ@rw.id.au>
+pkgname=py3-catkin-pkg-modules
+_pkgname=catkin_pkg_modules
+pkgver=0.4.12
+pkgrel=0
+pkgdesc="Standalone Python library for the catkin build system."
+url="http://wiki.ros.org/catkin_pkg"
+arch="noarch"
+license="BSD-3-Clause"
+options="!check" # python deps not packaged: flake8-blind-except flake8-builtins
+ # flake8-class-newline flake8-comprehensions flake8-deprecated
+ # flake8-docstrings flake8-import-order flake8-quotes
+depends="py3-docutils py3-dateutil py3-parsing"
+makedepends="python3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="ce04475b9d974cf08e1bd9f1cce9e476975d6d8162d00d856c3fa0e3155b95b1a5d68f1992d5be2ccd8cb7b9c5eba7a62b85062537e30368708ee4f2c8d7fe5f catkin_pkg_modules-0.4.12.tar.gz"