aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-05 06:55:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-05 08:13:25 -0300
commit9f952acf69b0bd35943fa20db7cece414df15c6e (patch)
treedb9023fcbfaaa91622828671500fc05f302425bf
parent6c688b4e322208c307f892452385adef194110e3 (diff)
testing/py3-codecov: upgrade to 2.0.15
-rw-r--r--testing/py3-codecov/APKBUILD52
1 files changed, 18 insertions, 34 deletions
diff --git a/testing/py3-codecov/APKBUILD b/testing/py3-codecov/APKBUILD
index c7c9c55f89f..ec4c2db594c 100644
--- a/testing/py3-codecov/APKBUILD
+++ b/testing/py3-codecov/APKBUILD
@@ -1,52 +1,36 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer:
-pkgname=py-codecov
-pkgver=1.1.0
-pkgrel=2
+pkgname=py3-codecov
+pkgver=2.0.15
+pkgrel=0
pkgdesc="Report uploader for Codecov"
+options="!check" # Requires unpackaged 'ddt'
url="https://github.com/codecov/codecov-python"
arch="noarch"
license="Apache-2.0"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-options="!check" #no testsuite
+depends="python3 py3-coverage py3-requests py3-setuptools"
+checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://github.com/codecov/codecov-python/archive/v$pkgver.tar.gz"
builddir="$srcdir"/codecov-python-$pkgver
-build() {
- cd "$builddir"
- python2 setup.py --quiet build
- python3 setup.py --quiet build
-}
+replaces="py-codecov" # Backwards compatibility
+provides="py-codecov=$pkgver-r$pkgrel" # Backwards compatibility
-package() {
- cd "$builddir"
- mkdir -p "$pkgdir"/usr/bin
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
+build() {
+ python3 setup.py build
}
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
+check() {
+ py.test-3 tests/test.py
}
-_py() {
- local python="$1"
- local pyver="${1:6:1}"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
- cd "$builddir"
- $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
- local file; for file in "$subpkgdir"/usr/bin/*; do
- mv $file $file-$pyver
+ local file; for file in "$pkgdir"/usr/bin/*; do
+ mv $file $file-3
+ ln -s "${file##*/}"-3 $file
done
}
-sha512sums="d113a64f668f5faaaa4b0871e532eb89632c2bebf5c443aa9519b6f58bebb5643ce77cff608ed75e0fa91e90ace182b46c32094ac424395caeaaf092d09fbe65 py-codecov-1.1.0.tar.gz"
+sha512sums="53cf2dc9926e2009a3918dfc7317d1e93f6ba9e25c6bb5bcc42c81fb15c07593f4fabd24883f081719432a029ab4f399126dea4cd8ff92d5e0f53b7155b1e522 py3-codecov-2.0.15.tar.gz"