aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-20 03:39:11 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-20 03:39:13 +0000
commita09006d7241a22e5389f3b164d321a6f7212f782 (patch)
tree01fc153adc14c2f3f043debb20b9e5e8cb1c654e
parent02f96122b5325280cf87ad1426e8895d46e45208 (diff)
community/xarchiver: add basic check
Add basic check as upstream doesn't provide a test suite.
-rw-r--r--community/xarchiver/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/xarchiver/APKBUILD b/community/xarchiver/APKBUILD
index e1e36ff214e..c6836d6307e 100644
--- a/community/xarchiver/APKBUILD
+++ b/community/xarchiver/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xarchiver
pkgver=0.5.4.12
-pkgrel=0
+pkgrel=1
pkgdesc="GTK+ frontend to various command line archivers"
url="https://github.com/ib/xarchiver"
arch="all"
@@ -23,6 +23,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ ./src/xarchiver --help > /dev/null
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install