aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-07 02:04:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-07 06:02:18 +0000
commita0df2a5f1c1d75f35b7fc671a7efca1296bf32c7 (patch)
tree984783811b3b336ae1e663fce1f4336c5f456844
parent9f9e82ca217090c25378eedfa22bb69aeadd3e94 (diff)
main/shared-mime-info: upgrade to 2.0
-rw-r--r--main/shared-mime-info/APKBUILD33
1 files changed, 10 insertions, 23 deletions
diff --git a/main/shared-mime-info/APKBUILD b/main/shared-mime-info/APKBUILD
index 174aa7412e1..5533e46ba7d 100644
--- a/main/shared-mime-info/APKBUILD
+++ b/main/shared-mime-info/APKBUILD
@@ -1,42 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shared-mime-info
-pkgver=1.15
+pkgver=2.0
pkgrel=0
pkgdesc="Freedesktop.org Shared MIME Info"
url="http://freedesktop.org/Software/shared-mime-info"
arch="all"
license="GPL-2.0-or-later"
-makedepends="libxml2-dev libxml2-utils glib-dev intltool itstool"
+makedepends="meson itstool libxml2-utils xmlto libxml2-dev glib-dev"
install="$pkgname.post-deinstall"
triggers="$pkgname.trigger=/usr/share/mime"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/b27eb88e4155d8fccb8bb3cd12025d5b/shared-mime-info-$pkgver.tar.xz"
-
-# Tests fail with itstool < 2.0.6
-# https://gitlab.freedesktop.org/xdg/shared-mime-info/issues/115
-options="!check"
+source="https://gitlab.freedesktop.org/xdg/shared-mime-info/uploads/0440063a2e6823a4b1a6fb2f2af8350f/shared-mime-info-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ac_cv_func_fdatasync=no ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-update-mimedb
- make -j1
+ abuild-meson \
+ -Dupdate-mimedb=false \
+ . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- cd "$builddir"
- make check
+ meson test --no-rebuild -v -C output
}
package() {
- cd "$builddir"
- make -j1 DESTDIR="$pkgdir" install
-
- mkdir -p "$pkgdir"/usr/lib
- mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-
-sha512sums="3666aa500dfa6a28bd0524400c47fa16d90ae61f8c80f350fd895972319ec2f511618b8a7fa3cbde621edee46fde19e4506bda62f0bd2d0ede1b08d7bdb9aef2 shared-mime-info-1.15.tar.xz"
+sha512sums="f4a1ea9a408ffcff325e57585dec5862405e9fd6c79e444048039f3061676501c40168cecf8935d002644a702a21f08f0f7c680ef6a65fdf188e0d892f3cc085 shared-mime-info-2.0.tar.xz"