aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHakan Erduman <hakan@erduman.de>2022-02-22 08:15:58 +0000
committerpsykose <alice@ayaya.dev>2022-02-22 09:16:02 +0100
commita133c1c06cc22cc770c87ce11d4c42b23c223239 (patch)
tree0a48c0aafd66648f111eecf4aba8fd5735912cef
parent325088cc570b45488e8d89fe625c075bb8256000 (diff)
testing/xfce4-hamster-plugin: new aport
-rw-r--r--testing/xfce4-hamster-plugin/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/xfce4-hamster-plugin/APKBUILD b/testing/xfce4-hamster-plugin/APKBUILD
new file mode 100644
index 00000000000..92f660640c6
--- /dev/null
+++ b/testing/xfce4-hamster-plugin/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Hakan Erduman <hakan@erduman.de>
+pkgname=xfce4-hamster-plugin
+pkgver=1.17
+pkgrel=0
+pkgdesc="Recreation of the gnome-shell hamster extension as a xfce4 panel plugin."
+url="https://github.com/projecthamster/xfce4-hamster-plugin"
+arch="all"
+license="GPL-2.0-or-later"
+options="!check" # No test suite
+makedepends="
+ cmake
+ libxfce4ui-dev
+ libxfce4util-dev
+ samurai
+ xfce4-panel-dev
+ "
+subpackages="$pkgname-lang"
+source="$pkgname-$pkgver.tar.gz::https://github.com/projecthamster/xfce4-hamster-plugin/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=MinSizeRel
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+2bdde6638502f726613c06d19cfd2b82324454fc64232562ceb3582796d7937b6883dd3c9933e415ee242d79b082309c2ede86366e066104fce2a322164ce101 xfce4-hamster-plugin-1.17.tar.gz
+"