aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2021-11-10 09:09:13 +0000
committerAndy Postnikov <apostnikov@gmail.com>2021-11-10 21:56:38 +0000
commita282e1f45fb9e175fce00ec3181ebe9cad24efa7 (patch)
tree186306d258c269415511c66f371facab4478c367
parent98a5816f2bfd82fb743a434d7919533cf995d770 (diff)
community/snowball: upgrade to 2.2.0
-rw-r--r--community/snowball/APKBUILD8
-rw-r--r--community/snowball/libstemmer-library.patch47
2 files changed, 27 insertions, 28 deletions
diff --git a/community/snowball/APKBUILD b/community/snowball/APKBUILD
index 43736a3e189..d977b639d2a 100644
--- a/community/snowball/APKBUILD
+++ b/community/snowball/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=snowball
-pkgver=2.1.0
-pkgrel=3
+pkgver=2.2.0
+pkgrel=0
pkgdesc="Snowball rule-based stemming algorithms"
url="https://snowballstem.org/"
arch="all"
@@ -42,6 +42,6 @@ _libstemmerdev() {
mv "$builddir"/libstemmer.so $subpkgdir/usr/lib
}
sha512sums="
-1efd7d8ab58852987e83247048244882c517e32237c8cb3c0558b66ecfb075733ce8805ebb76041e6e7d6664c236054effe66838e7c524ee529ce869aa8134f0 snowball-2.1.0.tar.gz
-7f4c628b8803dde5c7184fbc03a975850fb12eca9b2345164cd2de72531c81e7a000a35594625cbe52b401858f0b10aa3dc6506d019e3c9ccfea1f1848df7c0d libstemmer-library.patch
+02c43313de9de2518ea51cfb11f1c29145fc046c7838329bfdefd70b604009ad44b6db8175c25b0db31f03db30a6aec5857aa35775a9c204ec976df9cae62957 snowball-2.2.0.tar.gz
+6e8976313c91b71a13e50c213b74cc037ff794bf38451e1a053813c00b963527c6ff1f7baece1645f15a38bce893c4484247f71a945275276cb7aa16a1414817 libstemmer-library.patch
"
diff --git a/community/snowball/libstemmer-library.patch b/community/snowball/libstemmer-library.patch
index ce2858978e9..a71142535c9 100644
--- a/community/snowball/libstemmer-library.patch
+++ b/community/snowball/libstemmer-library.patch
@@ -1,42 +1,41 @@
-diff --git a/GNUmakefile b/GNUmakefile
-index 5cb2179..7a2881a 100644
--- a/GNUmakefile
+++ b/GNUmakefile
-@@ -3,6 +3,7 @@
- # After changing this, run `make update_version` to update various sources
- # which hard-code it.
- SNOWBALL_VERSION = 2.1.0
-+MAJOR_VERSION := $(shell echo $(SNOWBALL_VERSION) | cut -d. -f1)
+@@ -8,6 +8,8 @@
+ EXEEXT = .exe
+ endif
++MAJOR_VERSION := $(shell echo $(SNOWBALL_VERSION) | cut -d. -f1)
++
c_src_dir = src_c
-@@ -162,10 +163,23 @@ C_OTHER_OBJECTS = $(C_OTHER_SOURCES:.c=.o)
+ JAVAC ?= javac
+@@ -170,12 +172,12 @@
JAVA_CLASSES = $(JAVA_SOURCES:.java=.class)
JAVA_RUNTIME_CLASSES=$(JAVARUNTIME_SOURCES:.java=.class)
-CFLAGS=-O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
--CPPFLAGS=-Iinclude
-+CFLAGS+=-fPIC -W -Wall -Wmissing-prototypes -Wmissing-declarations
-+CPPFLAGS+=-Iinclude
-
--all: snowball libstemmer.o stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
-+all: snowball libstemmer.o libstemmer.so libstemmer.a stemwords $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
-+libstemmer.o: libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
-+ $(AR) -cru $@ $^
++CFLAGS=-fPIC -O2 -W -Wall -Wmissing-prototypes -Wmissing-declarations
+ CPPFLAGS=
+
+ INCLUDES=-Iinclude
+
+-all: snowball$(EXEEXT) libstemmer.a stemwords$(EXEEXT) $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
++all: snowball$(EXEEXT) libstemmer.a libstemmer.so stemwords$(EXEEXT) $(C_OTHER_SOURCES) $(C_OTHER_HEADERS) $(C_OTHER_OBJECTS)
+
+ algorithms.mk: libstemmer/mkalgorithms.pl libstemmer/modules.txt
+ libstemmer/mkalgorithms.pl algorithms.mk libstemmer/modules.txt
+@@ -224,6 +226,11 @@
+
+ libstemmer.a: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
+ $(AR) -cru $@ $^
+
+libstemmer.so: libstemmer/libstemmer.o $(RUNTIME_OBJECTS) $(C_LIB_OBJECTS)
+ $(CC) $(CFLAGS) -shared $(LDFLAGS) -Wl,-soname,$@.$(MAJOR_VERSION),-version-script,libstemmer/symbol.map -o $@.$(SNOWBALL_VERSION) $^
+ ln -s $@.$(SNOWBALL_VERSION) $@.$(MAJOR_VERSION)
+ ln -s $@.$(SNOWBALL_VERSION) $@
-+
-+libstemmer.a: libstemmer.o
-+ $(AR) -crs $@ $^
-+
-+stemwords: $(STEMWORDS_OBJECTS) libstemmer.o
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
- clean:
- rm -f $(COMPILER_OBJECTS) $(RUNTIME_OBJECTS) \
+ examples/%.o: examples/%.c
+ $(CC) $(CFLAGS) $(INCLUDES) $(CPPFLAGS) -c -o $@ $<
--- /dev/null
+++ b/libstemmer/symbol.map
@@ -0,0 +1,6 @@