aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-20 14:48:03 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-20 15:06:18 +0000
commita3efd2201497ad88f4dbc6693599a5cc1abacf31 (patch)
tree80ed5ca433db05c89ed92f412957b26447c8f512
parentf0a95f57dd7b7da81043634e03733b3e81390b3b (diff)
community/mtd-utils: make find invocations compliant
The Busybox version of find allows parameters to be specified between '{}' and '+' as argument to -exec. This however is not according to the posix specification, and the GNU version of find doesn't accept it. Use the coreutils version of 'mv' with the '-t' arguement to be able to specify the filenames as last.
-rw-r--r--community/mtd-utils/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/mtd-utils/APKBUILD b/community/mtd-utils/APKBUILD
index e5b1af9a562..a8dfdd9ba15 100644
--- a/community/mtd-utils/APKBUILD
+++ b/community/mtd-utils/APKBUILD
@@ -10,6 +10,7 @@ makedepends="
acl-dev
autoconf
automake
+ coreutils
cmocka-dev
libtool
linux-headers
@@ -65,8 +66,8 @@ flash() {
mkdir -p "$subpkgdir/usr/sbin"
find "$pkgdir/usr/sbin/" -type f \( \
- -iname '*flash*' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -iname '*flash*' \) \
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
jffs() {
@@ -76,7 +77,7 @@ jffs() {
mkdir -p "$subpkgdir/usr/sbin"
find "$pkgdir/usr/sbin/" -type f \(\
-iname '*jffs*' -o -iname 'sumtool' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
misc() {
@@ -87,7 +88,7 @@ misc() {
-iname '*doc*' -o -iname 'ftl*' -o \
-iname 'mtdpart' -o -iname 'mtd_debug' -o \
-iname 'recv_image' -o -iname 'serve_image' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
nand() {
@@ -96,7 +97,7 @@ nand() {
mkdir -p "$subpkgdir/usr/sbin"
find "$pkgdir/usr/sbin/" -type f \(\
-iname 'nand*' -o -iname 'nftl*' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
nor() {
@@ -105,7 +106,7 @@ nor() {
mkdir -p "$subpkgdir/usr/sbin"
find "$pkgdir/usr/sbin/" -type f \(\
-iname '*nor*' -o -iname 'rfd*' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
ubi() {
@@ -115,7 +116,7 @@ ubi() {
find "$pkgdir/usr/sbin/" -type f \(\
-iname '*ubi*' -o \
-iname 'lsmtd' -o -iname 'mtdinfo' \)\
- -exec mv "{}" "$subpkgdir/usr/sbin/" +
+ -exec mv -t "$subpkgdir/usr/sbin/" "{}" +
}
package() {