aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hills <mark@xwax.org>2020-11-20 19:36:09 +0000
committerLeo <thinkabit.ukim@gmail.com>2021-01-09 23:52:47 +0000
commita425be33d24e7e7628dc42e45cb71aaf26661194 (patch)
tree5bb461aa049e6eaffad980151efc6dcf7bc06568
parent6e93652ddf9bc9a199a494603790e612a64da807 (diff)
testing/cronie: new aport
-rw-r--r--testing/cronie/APKBUILD54
-rw-r--r--testing/cronie/cronie.confd1
-rw-r--r--testing/cronie/cronie.initd9
3 files changed, 64 insertions, 0 deletions
diff --git a/testing/cronie/APKBUILD b/testing/cronie/APKBUILD
new file mode 100644
index 00000000000..0d4af49e894
--- /dev/null
+++ b/testing/cronie/APKBUILD
@@ -0,0 +1,54 @@
+# Contributor: Mark Hills <mark@xwax.org>
+# Maintainer: Mark Hills <mark@xwax.org>
+pkgname=cronie
+pkgver=1.5.5
+pkgrel=0
+pkgdesc="The standard UNIX daemon crond that runs specified programs at scheduled times"
+url="https://github.com/cronie-crond/cronie"
+arch="all"
+license="ISC"
+makedepends="autoconf automake musl-obstack-dev"
+options="suid !check" # No testsuite
+subpackages="$pkgname-doc $pkgname-openrc"
+source="
+ https://github.com/cronie-crond/cronie/releases/download/cronie-$pkgver/cronie-$pkgver.tar.gz
+ cronie.initd
+ cronie.confd
+ "
+
+build() {
+ export LIBS="-lobstack"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --without-pam \
+ --without-selinux \
+ --with-inotify \
+ SPOOL_DIR=/etc/crontabs
+ make
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname
+
+ mkdir "$pkgdir"/etc/cron.d
+
+ # Ordinary users access to edit content of the crontabs directory
+ chmod 6755 "$pkgdir"/usr/bin/crontab
+
+ # Default is all users can access cron
+ touch "$pkgdir"/etc/cron.deny
+}
+
+sha512sums="3cb53ee4db7722c0764a1d2e5dfe773cfc31c91e9d0798d579a58ec8c29a1f42238e18c27baae2eaff6df37250cd06dddbf77f0020aed68b9712fd7332efb912 cronie-1.5.5.tar.gz
+309ac59de5212e814e8f68f0619e91a1459092392dd38d85c72740c635a6e50f232cfcdb883eccff203c7254bc94f60fe203150137a0862c3802ace58d5fcc22 cronie.initd
+caabbeb35c8bfed5f139063416cb6667ab066918e8ef57b057bf4d7bbb005ad6cc5d34687e52ed22f8152e61f4c35709e895652497600a7194cdfb04d48ca152 cronie.confd"
diff --git a/testing/cronie/cronie.confd b/testing/cronie/cronie.confd
new file mode 100644
index 00000000000..5d178e21b2c
--- /dev/null
+++ b/testing/cronie/cronie.confd
@@ -0,0 +1 @@
+CRON_OPTS=""
diff --git a/testing/cronie/cronie.initd b/testing/cronie/cronie.initd
new file mode 100644
index 00000000000..93652a78389
--- /dev/null
+++ b/testing/cronie/cronie.initd
@@ -0,0 +1,9 @@
+#!/sbin/openrc-run
+
+name="$SVCNAME"
+command="/usr/sbin/crond"
+command_args="$CRON_OPTS"
+
+depend() {
+ provide cron
+}