aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Hencke <robert.hencke@gmail.com>2018-12-27 12:33:15 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-31 14:42:52 +0000
commita48553e706244b88d2af557f8b0cf9917c72c22d (patch)
treeafdfb1da4e85dc3d9dbf8f4fb88a6f5463e04a0b
parentc93151cf8f66ecdcc92fd46b5f73ef404d1c5b94 (diff)
testing/xfce4-genmon-plugin: new aport
https://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin A generic, script-driven monitoring plugin for the Xfce panel
-rw-r--r--testing/xfce4-genmon-plugin/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/xfce4-genmon-plugin/APKBUILD b/testing/xfce4-genmon-plugin/APKBUILD
new file mode 100644
index 00000000000..49f184b153e
--- /dev/null
+++ b/testing/xfce4-genmon-plugin/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Robert Hencke <robert.hencke@gmail.com>
+pkgname=xfce4-genmon-plugin
+pkgver=4.0.1
+pkgrel=0
+pkgdesc="A generic, script-driven monitoring plugin for the Xfce panel"
+url="http://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin"
+arch="all"
+license="LGPL-2.1"
+makedepends="xfce4-panel-dev libxfce4ui-dev"
+options="!check" # no tests
+subpackages="$pkgname-lang"
+source="http://archive.xfce.org/src/panel-plugins/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="14590ba4a3b31773e38139d274c93060b2dfdf3cd476dc2235f95f987529b93b74d2422507cc4bf1152f376ec9c6a01bd1da903d422757b95b19c01aa412b35e xfce4-genmon-plugin-4.0.1.tar.bz2"