aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-12-10 11:59:19 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-12-10 11:22:56 +0000
commita4abde86e6aa9632b0116941c89380e5df82a0de (patch)
tree00ce29819f228a968552511b4c207ce9656b1bed
parentfb406f4e6831562f9279f0a24d4eb059be082074 (diff)
community/sysprof: upgrade to 3.38.1
-rw-r--r--community/sysprof/APKBUILD8
-rw-r--r--community/sysprof/fix-32-bit-build.patch13
2 files changed, 3 insertions, 18 deletions
diff --git a/community/sysprof/APKBUILD b/community/sysprof/APKBUILD
index e1fbc93c751..b709d2d9004 100644
--- a/community/sysprof/APKBUILD
+++ b/community/sysprof/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=sysprof
-pkgver=3.36.0
+pkgver=3.38.1
pkgrel=0
pkgdesc="System-wide profiler for Linux"
url="http://sysprof.com/"
@@ -12,8 +12,7 @@ makedepends="meson gtk+3.0-dev itstool glib-dev polkit-dev elogind-dev
libdazzle-dev"
options="!check" # test-model-filter fails
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/sysprof/${pkgver%.*}/sysprof-$pkgver.tar.xz
- fix-32-bit-build.patch"
+source="https://download.gnome.org/sources/sysprof/${pkgver%.*}/sysprof-$pkgver.tar.xz"
build() {
abuild-meson \
@@ -31,5 +30,4 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4 sysprof-3.36.0.tar.xz
-c03fc64a4fdb19e4b3e21ef42e9f21a2af8ed33cdb503314fbb2d826ec6ad4b5e57078191553681be21934aca30442c7b2662facd28a499e86107d148ed96773 fix-32-bit-build.patch"
+sha512sums="7ba3dd51bd4055dcdf4d46ff87e46537afe42ba009809fdee5ba0ebcdf70776d9e1ff812714096d33b09ac57d459707b92b1ca07682e2f3888b612ca74820442 sysprof-3.38.1.tar.xz"
diff --git a/community/sysprof/fix-32-bit-build.patch b/community/sysprof/fix-32-bit-build.patch
deleted file mode 100644
index 22b2b2fea68..00000000000
--- a/community/sysprof/fix-32-bit-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/tests/allocs-by-size.c b/src/tests/allocs-by-size.c
-index 666113a..6260d4b 100644
---- a/src/tests/allocs-by-size.c
-+++ b/src/tests/allocs-by-size.c
-@@ -109,7 +109,7 @@ allocs_by_size (SysprofCaptureReader *reader)
- {
- const Item *item = &g_array_index (ar, Item, i);
-
-- g_print ("%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT"\n",
-+ g_print ("%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT"\n",
- item->size, item->cmp, item->count);
- }
- }