aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-02-07 13:56:07 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-02-07 13:56:07 +0000
commita4cd7f41cacdd521a1bc2528d36735e49b46d9ed (patch)
tree483fdf521bfcea51f4f399e62168ab3aee5e4791
parentfe1907eabe4fb94b9e5f5e771697527d57cbae6c (diff)
testing/mailx: moved from unstable to testing
downgraded and added patches taken from archlinux
-rw-r--r--testing/mailx/APKBUILD44
-rw-r--r--testing/mailx/mailx-8.1.1.patch31
-rw-r--r--testing/mailx/mailx-gcc4.patch12
-rw-r--r--unstable/mailx/APKBUILD30
4 files changed, 87 insertions, 30 deletions
diff --git a/testing/mailx/APKBUILD b/testing/mailx/APKBUILD
new file mode 100644
index 00000000000..bf3ea73195c
--- /dev/null
+++ b/testing/mailx/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=mailx
+pkgver=8.1.1
+pkgrel=0
+pkgdesc="A commandline utility for sending email"
+url="http://www.opengroup.org/onlinepubs/007908799/xcu/mailx.html"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="ftp://ftp.archlinux.org/other/mailx/$pkgname-$pkgver-fixed.tar.gz
+ mailx-8.1.1.patch
+ mailx-gcc4.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver-fixed"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i 's#/man/#/share/man/#' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="63cad526ac64b57bcba2c0daaa1f3048 mailx-8.1.1-fixed.tar.gz
+d66b9f419c5d215271ed434f5d780843 mailx-8.1.1.patch
+8716c7c7b3f5d348443230e2fe543bf6 mailx-gcc4.patch"
diff --git a/testing/mailx/mailx-8.1.1.patch b/testing/mailx/mailx-8.1.1.patch
new file mode 100644
index 00000000000..536c28fc561
--- /dev/null
+++ b/testing/mailx/mailx-8.1.1.patch
@@ -0,0 +1,31 @@
+--- Makefile Thu Mar 16 09:30:36 2000
++++ Makefile Wed Feb 27 12:50:09 2002
+@@ -7,18 +7,20 @@
+ BINOWN = root
+ BINGRP = mail
+
++DESTDIR =
++
+ all:
+ gcc $(SRCS) -o $(PROG)
+
+ install:
+- mkdir -p /usr/share/misc
+- mkdir -p /usr/share/man/man1
+- mkdir -p /etc
+- mkdir -p /usr/bin
+- install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) /usr/bin
+- install -o root -g root -m 644 mail.1 /usr/share/man/man1
++ mkdir -p $(DESTDIR)/usr/share/misc
++ mkdir -p $(DESTDIR)/usr/man/man1
++ mkdir -p $(DESTDIR)/etc
++ mkdir -p $(DESTDIR)/usr/bin
++ install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) $(DESTDIR)/usr/bin
++ install -o root -g root -m 644 mail.1 $(DESTDIR)/usr/man/man1
+ cd misc; install -c -o ${BINOWN} -g ${BINGRP} \
+- -m 444 ${SFILES} /usr/share/misc
++ -m 444 ${SFILES} $(DESTDIR)/usr/share/misc
+ cd misc; install -c -o root -g root \
+- -m 644 ${EFILES} /etc
++ -m 644 ${EFILES} $(DESTDIR)/etc
+
diff --git a/testing/mailx/mailx-gcc4.patch b/testing/mailx/mailx-gcc4.patch
new file mode 100644
index 00000000000..54740a23020
--- /dev/null
+++ b/testing/mailx/mailx-gcc4.patch
@@ -0,0 +1,12 @@
+K. Piche: Unofficial patch for mailx.
+
+--- dotlock.c.orig 2005-09-18 20:28:20.000000000 -0400
++++ dotlock.c 2005-09-18 20:26:59.000000000 -0400
+@@ -47,6 +47,7 @@
+ #include <errno.h>
+ #include <signal.h>
+
++#include "def.h"
+ #include "extern.h"
+
+ #ifndef O_SYNC
diff --git a/unstable/mailx/APKBUILD b/unstable/mailx/APKBUILD
deleted file mode 100644
index b8d82aeeca6..00000000000
--- a/unstable/mailx/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
-pkgname=mailx
-pkgver=8.1.2
-pkgrel=0
-pkgdesc="The /bin/mail program, which is used to send mail via shell scripts"
-url="www.debian.org"
-license="GPL"
-depends=""
-makedepends=""
-install=
-subpackages="$pkgname-dev $pkgname-doc"
-source="ftp://ftp.debian.org/debian/pool/main/m/mailx/"$pkgname"_"$pkgver"-0.20050715cvs.orig.tar.gz"
-
-
-build() {
- #mailx-8.1.2-0.20050715cvs.orig
- cd "$srcdir"/$pkgname-$pkgver-0.20050715cvs.orig
-#will have to patch...
-# for i in ../*.patch; do
-# msg "Appling $i..."
-# patch -p1 < $i || return 1
-# done
-
- make || return 1
- make DESTDIR="$pkgdir" install
-
-}
-
-md5sums="3ba08abd8bbd0a87ea5bad05cded3bc3 mailx_8.1.2-0.20050715cvs.orig.tar.gz"