aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-07-27 02:51:07 +0000
committerpsykose <alice@ayaya.dev>2022-07-27 04:51:07 +0200
commita64b1b800e033e7d7f8f0ccd73f6cd827096d05c (patch)
tree1de7e4869f2b102745ef263bb53395ba11d99d35
parentb17b5ef0434149f4f3262dcad5fcb5c446845151 (diff)
community/qbittorrent: add tiny -dbg
-rw-r--r--community/qbittorrent/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/qbittorrent/APKBUILD b/community/qbittorrent/APKBUILD
index ba5209a62c7..675e0612388 100644
--- a/community/qbittorrent/APKBUILD
+++ b/community/qbittorrent/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=qbittorrent
pkgver=4.4.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="qBittorrent client"
url="https://www.qbittorrent.org/"
arch="all"
@@ -13,12 +13,13 @@ makedepends="
boost-dev
cmake
libtorrent-rasterbar-dev
- ninja
qt6-qtbase-dev
qt6-qtsvg-dev
qt6-qttools-dev
+ samurai
"
subpackages="
+ $pkgname-dbg
$pkgname-doc
$pkgname-nox
$pkgname-nox-openrc:nox_openrc
@@ -36,6 +37,9 @@ builddir="$srcdir/qBittorrent-release-$pkgver"
# - CVE-2019-13640
build() {
+ export CFLAGS="${CFLAGS/-g/-g1}"
+ export CXXFLAGS="${CXXFLAGS/-g/-g1}"
+
cmake -B build-gui -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \