aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2021-06-30 10:04:58 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2021-06-30 10:04:58 +0000
commita6509dcbec55ef87e52e32a08993e9c3c88bb1a6 (patch)
tree6b5c3f568d5a56e76c6156e2afd686d5ac84e970
parent3773318f456691e631ddd99331496df0abc285a9 (diff)
downloadaports-a6509dcbec55ef87e52e32a08993e9c3c88bb1a6.tar.gz
aports-a6509dcbec55ef87e52e32a08993e9c3c88bb1a6.tar.bz2
aports-a6509dcbec55ef87e52e32a08993e9c3c88bb1a6.tar.xz
community various: disable on riscv64 due to missing rust
all these packages have recursive dep on rust and are blocked
-rw-r--r--community/kleopatra/APKBUILD3
-rw-r--r--community/kmediaplayer/APKBUILD3
-rw-r--r--community/knetwalk/APKBUILD3
-rw-r--r--community/knotes/APKBUILD3
-rw-r--r--community/kontact/APKBUILD3
-rw-r--r--community/kontrast/APKBUILD3
-rw-r--r--community/kteatime/APKBUILD3
-rw-r--r--community/ktouch/APKBUILD3
-rw-r--r--community/kweather/APKBUILD3
-rw-r--r--community/lightdm/APKBUILD3
-rw-r--r--community/lollypop/APKBUILD3
-rw-r--r--community/mailcommon/APKBUILD3
-rw-r--r--community/mate-desktop-environment/APKBUILD3
-rw-r--r--community/mate-screensaver/APKBUILD3
-rw-r--r--community/megapixels/APKBUILD3
-rw-r--r--community/mutter/APKBUILD3
-rw-r--r--community/mycroft-plasmoid/APKBUILD3
-rw-r--r--community/nemo/APKBUILD4
-rw-r--r--community/peruse/APKBUILD3
-rw-r--r--community/phosh/APKBUILD3
-rw-r--r--community/php7-pecl-vips/APKBUILD3
-rw-r--r--community/php8-pecl-vips/APKBUILD3
-rw-r--r--community/plasma-angelfish/APKBUILD3
-rw-r--r--community/plasma-dialer/APKBUILD3
-rw-r--r--community/plasma/APKBUILD3
-rw-r--r--community/portfolio/APKBUILD3
-rw-r--r--community/postmarketos-ondev/APKBUILD3
-rw-r--r--community/qqc2-breeze-style/APKBUILD3
-rw-r--r--community/rkward/APKBUILD3
-rw-r--r--community/rocs/APKBUILD3
-rw-r--r--community/sddm/APKBUILD3
-rw-r--r--community/seahorse/APKBUILD3
-rw-r--r--community/simple-scan/APKBUILD3
-rw-r--r--community/sound-juicer/APKBUILD3
-rw-r--r--community/step/APKBUILD3
-rw-r--r--community/sxmo-utils/APKBUILD3
-rw-r--r--community/sxmo-xdm-config/APKBUILD3
-rw-r--r--community/telepathy-ofono/APKBUILD3
-rw-r--r--community/tootle/APKBUILD3
-rw-r--r--community/umbrello/APKBUILD3
-rw-r--r--community/urfkill/APKBUILD3
-rw-r--r--community/weston/APKBUILD3
-rw-r--r--community/xdg-desktop-portal-gtk/APKBUILD3
43 files changed, 86 insertions, 44 deletions
diff --git a/community/kleopatra/APKBUILD b/community/kleopatra/APKBUILD
index bffd9c7f1c..c701b85bf2 100644
--- a/community/kleopatra/APKBUILD
+++ b/community/kleopatra/APKBUILD
@@ -3,7 +3,8 @@
pkgname=kleopatra
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.kde.org/applications/utilities/kleopatra/"
pkgdesc="Certificate Manager and Unified Crypto GUI"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmediaplayer/APKBUILD b/community/kmediaplayer/APKBUILD
index 5220f0fd09..3994ec82e2 100644
--- a/community/kmediaplayer/APKBUILD
+++ b/community/kmediaplayer/APKBUILD
@@ -4,7 +4,8 @@ pkgname=kmediaplayer
pkgver=5.83.0
pkgrel=0
pkgdesc="Media player framework for KDE 5"
-arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips64 !s390x !riscv64" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="X11 AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kparts-dev kxmlgui-dev"
diff --git a/community/knetwalk/APKBUILD b/community/knetwalk/APKBUILD
index 7722752522..d266516e55 100644
--- a/community/knetwalk/APKBUILD
+++ b/community/knetwalk/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="Connect all the terminals to the server, in as few turns as possible"
# armhf blocked by extra-cmake-modules
# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://kde.org/applications/games/knetwalk/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/knotes/APKBUILD b/community/knotes/APKBUILD
index d056d118cd..9bf513955a 100644
--- a/community/knotes/APKBUILD
+++ b/community/knotes/APKBUILD
@@ -5,7 +5,8 @@ pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
# mips, ppc64le and s390x blocked by kdepim-runtime
-arch="all !armhf !ppc64le !s390x !mips !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !ppc64le !s390x !mips !mips64 !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Popup notes"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index 1b433e1262..f7009ed32d 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -5,7 +5,8 @@ pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
diff --git a/community/kontrast/APKBUILD b/community/kontrast/APKBUILD
index c644158d71..366b010090 100644
--- a/community/kontrast/APKBUILD
+++ b/community/kontrast/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="Tool to check contrast for colors that allows verifying that your colors are correctly accessible"
# armhf blocked by qt5-qtdeclarative
# s390x, mips64 and riscv64 blocked by polkit -> kdeclarative
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://invent.kde.org/accessibility/kontrast"
license="GPL-3.0-or-later AND CC0-1.0"
depends="kirigami2"
diff --git a/community/kteatime/APKBUILD b/community/kteatime/APKBUILD
index ed364bc659..65ad150d7f 100644
--- a/community/kteatime/APKBUILD
+++ b/community/kteatime/APKBUILD
@@ -3,7 +3,8 @@
pkgname=kteatime
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !mips !mips64 !s390x"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips !mips64 !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kteatime"
pkgdesc="A handy timer for steeping tea"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/ktouch/APKBUILD b/community/ktouch/APKBUILD
index 5692c67800..7d28e9758a 100644
--- a/community/ktouch/APKBUILD
+++ b/community/ktouch/APKBUILD
@@ -3,7 +3,8 @@
pkgname=ktouch
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !mips !mips64 !s390x" # armhf blocked by qt5-qtdeclarative, everything else by rust
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips !mips64 !s390x !riscv64" # armhf blocked by qt5-qtdeclarative, everything else by rust
url="https://edu.kde.org/ktouch/"
pkgdesc="Touch Typing Tutor"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kweather/APKBUILD b/community/kweather/APKBUILD
index 281172eab2..3c6d4709b5 100644
--- a/community/kweather/APKBUILD
+++ b/community/kweather/APKBUILD
@@ -7,7 +7,8 @@ pkgdesc="Weather application for Plasma Mobile"
url="https://invent.kde.org/plasma-mobile/kweather"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by plasma-framework
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
license="GPL-2.0-or-later AND CC-BY-4.0"
depends="
kirigami2
diff --git a/community/lightdm/APKBUILD b/community/lightdm/APKBUILD
index fd742323dc..39a1b899d2 100644
--- a/community/lightdm/APKBUILD
+++ b/community/lightdm/APKBUILD
@@ -5,7 +5,8 @@ pkgver=1.30.0
pkgrel=5
pkgdesc="cross-desktop display manager"
url="https://www.freedesktop.org/wiki/Software/LightDM"
-arch="all !s390x !mips !mips64" # gnome-themes-standard missing due to librsvg
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # gnome-themes-standard missing due to librsvg
license="GPL-3.0-or-later"
depends="dbus xinit accountsservice gnome-themes-standard
adwaita-icon-theme"
diff --git a/community/lollypop/APKBUILD b/community/lollypop/APKBUILD
index d137e15b87..7ab7c44139 100644
--- a/community/lollypop/APKBUILD
+++ b/community/lollypop/APKBUILD
@@ -7,7 +7,8 @@ _pover=839c22622aa106fe63e7bda409b4f25f172ecd04
pkgrel=1
pkgdesc="Music player for GNOME"
url="https://gitlab.gnome.org/World/Lollypop"
-arch="noarch !mips !mips64 !s390x" # libhandy missing
+# riscv64 disabled due to missing rust in recursive dependency
+arch="noarch !mips !mips64 !s390x !riscv64" # libhandy missing
license="GPL-3.0-only"
depends="python3 libhandy1 libsecret libsoup py3-cairo py3-gobject3 py3-gst py3-pillow py3-pylast totem-pl-parser"
makedepends="gobject-introspection-dev gtk+3.0-dev libhandy1-dev libsoup-dev
diff --git a/community/mailcommon/APKBUILD b/community/mailcommon/APKBUILD
index 0407f92ea8..e391e51970 100644
--- a/community/mailcommon/APKBUILD
+++ b/community/mailcommon/APKBUILD
@@ -4,7 +4,8 @@ pkgname=mailcommon
pkgver=21.04.2
pkgrel=0
pkgdesc="KDE PIM library providing support for mail applications"
-arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by messagelib -> qt5-qtwebengine
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64" # Limited by messagelib -> qt5-qtwebengine
url="https://kontact.kde.org/"
license="GPL-2.0-or-later"
depends_dev="
diff --git a/community/mate-desktop-environment/APKBUILD b/community/mate-desktop-environment/APKBUILD
index 41a2d881c3..8e14fadf70 100644
--- a/community/mate-desktop-environment/APKBUILD
+++ b/community/mate-desktop-environment/APKBUILD
@@ -4,7 +4,8 @@ pkgver=1.24.0
pkgrel=1
pkgdesc="Metapackage for MATE desktop environment"
url="https://mate-desktop.org/"
-arch="all !s390x !mips !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64"
license="GPL-2.0-or-later LGPL-2.0-or-later"
depends="caja
caja-extensions>=$pkgver
diff --git a/community/mate-screensaver/APKBUILD b/community/mate-screensaver/APKBUILD
index 6894d55d66..f09378f63b 100644
--- a/community/mate-screensaver/APKBUILD
+++ b/community/mate-screensaver/APKBUILD
@@ -5,7 +5,8 @@ pkgver=1.24.2
pkgrel=0
pkgdesc="A screen saver and locker for MATE"
url="https://github.com/mate-desktop/mate-screensaver"
-arch="all !s390x !mips !mips64" # mate-desktop
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # mate-desktop
license="GPL-2.0-or-later"
makedepends="intltool glib-dev libxscrnsaver-dev gtk+3.0-dev
mate-desktop-dev dbus-glib-dev mate-menus-dev dconf-dev
diff --git a/community/megapixels/APKBUILD b/community/megapixels/APKBUILD
index 4ea18f20f6..60c0bf9d43 100644
--- a/community/megapixels/APKBUILD
+++ b/community/megapixels/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="GTK+4 camera app for mobile devices"
url="https://git.sr.ht/~martijnbraam/megapixels"
# s390x and mips64 blocked by gtk4.0
-arch="all !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips64 !riscv64"
license="GPL-3.0-only"
# Required by postprocess.sh
# depends="cmd:dcraw_emu cmd:convert cmd:exiftool"
diff --git a/community/mutter/APKBUILD b/community/mutter/APKBUILD
index ae195f3b06..bce64e7fed 100644
--- a/community/mutter/APKBUILD
+++ b/community/mutter/APKBUILD
@@ -5,7 +5,8 @@ pkgver=40.1
pkgrel=0
pkgdesc="clutter-based window manager and compositor"
url="https://wiki.gnome.org/Projects/Mutter/"
-arch="all !s390x !mips !mips64" # limited by gnome-settings-daemon, s390x: and pipewire
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # limited by gnome-settings-daemon, s390x: and pipewire
license="GPL-2.0-or-later"
depends="xkeyboard-config zenity gsettings-desktop-schemas xwayland"
makedepends="gnome-desktop-dev libcanberra-dev upower-dev json-glib-dev
diff --git a/community/mycroft-plasmoid/APKBUILD b/community/mycroft-plasmoid/APKBUILD
index 3dcda9cca7..7aaeec3246 100644
--- a/community/mycroft-plasmoid/APKBUILD
+++ b/community/mycroft-plasmoid/APKBUILD
@@ -7,7 +7,8 @@ _commit="70f84636da63b00d114747e440e4a15aa7d5b019"
pkgdesc="Plasma integration of different Mycroft AI services"
url="https://invent.kde.org/utilities/mycroft-plasmoid"
# ppc64le, s390x, armhf, mips and mips64 blocked by mycroft-gui
-arch="all !ppc64le !s390x !armhf !mips !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
license="Apache-2.0 AND LGPL-2.0-or-later AND LicenseRef-KDE-Accepted-GPL"
depends="mycroft-gui"
makedepends="
diff --git a/community/nemo/APKBUILD b/community/nemo/APKBUILD
index 01cac1eada..6d795adaad 100644
--- a/community/nemo/APKBUILD
+++ b/community/nemo/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.8.6
pkgrel=0
pkgdesc="File manager for the Cinnamon desktop environment"
# s390x, mips64 and ppc64le blocked by exempi
-# riscv64 blocked by polkit -> gvfs
-arch="all !s390x !mips64 !ppc64le" # exempi, libexif-dev not available for all archs
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips64 !ppc64le !riscv64" # exempi, libexif-dev not available for all archs
url="https://github.com/linuxmint/nemo"
license="GPL-2.0-only"
makedepends="
diff --git a/community/peruse/APKBUILD b/community/peruse/APKBUILD
index c20c41ab21..e62b440ffc 100644
--- a/community/peruse/APKBUILD
+++ b/community/peruse/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="A comic book viewer based on Frameworks 5, for use on multiple form factors"
# armhf blocked by extra-cmake-modules
# s390x and mips64 blocked by kdeclarative
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://invent.kde.org/graphics/peruse"
license="LGPL-2.1-or-later AND LicenseRef-KDE-Accepted-LGPL"
depends="
diff --git a/community/phosh/APKBUILD b/community/phosh/APKBUILD
index 3e02d3e884..b1365f6a1a 100644
--- a/community/phosh/APKBUILD
+++ b/community/phosh/APKBUILD
@@ -7,7 +7,8 @@ pkgrel=0
pkgdesc="Shell PoC for the Librem5"
# Blocked on mips and s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
# Blocked on ppc64le by gnome-session
-arch="all !s390x !ppc64le !mips !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !ppc64le !mips !mips64 !riscv64"
url="https://source.puri.sm/Librem5/phosh"
license="GPL-3.0-only"
depends="wayland-protocols phoc gnome-session bash dbus-x11 gnome-settings-daemon
diff --git a/community/php7-pecl-vips/APKBUILD b/community/php7-pecl-vips/APKBUILD
index 62d2174844..648eb9c772 100644
--- a/community/php7-pecl-vips/APKBUILD
+++ b/community/php7-pecl-vips/APKBUILD
@@ -6,7 +6,8 @@ pkgver=1.0.12
pkgrel=0
pkgdesc="PHP extension for interfacing with vips - PECL"
url="https://pecl.php.net/package/vips"
-arch="all !s390x !ppc64le !mips !mips64" # Limited by vips aport
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !ppc64le !mips !mips64 !riscv64" # Limited by vips aport
license="MIT"
depends="php7-common"
makedepends="php7-dev autoconf vips-dev"
diff --git a/community/php8-pecl-vips/APKBUILD b/community/php8-pecl-vips/APKBUILD
index 3c93ab5181..c65c214a1e 100644
--- a/community/php8-pecl-vips/APKBUILD
+++ b/community/php8-pecl-vips/APKBUILD
@@ -6,7 +6,8 @@ pkgver=1.0.12
pkgrel=0
pkgdesc="PHP 8 extension for interfacing with vips - PECL"
url="https://pecl.php.net/package/vips"
-arch="all !s390x !ppc64le !mips !mips64" # Limited by vips aport
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !ppc64le !mips !mips64 !riscv64" # Limited by vips aport
license="MIT"
depends="php8-common"
makedepends="php8-dev vips-dev"
diff --git a/community/plasma-angelfish/APKBUILD b/community/plasma-angelfish/APKBUILD
index f99e77a042..74296cb52f 100644
--- a/community/plasma-angelfish/APKBUILD
+++ b/community/plasma-angelfish/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="Small Webbrowser for Plasma Mobile"
# armhf blocked by extra-cmake-modules
# ppc64le, s390x and mips64 blocked by qt5-qtwebengine
-arch="all !ppc64le !s390x !armhf !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !ppc64le !s390x !armhf !mips64 !riscv64"
url="https://phabricator.kde.org/source/plasma-angelfish/"
license="GPL-3.0-or-later"
depends="
diff --git a/community/plasma-dialer/APKBUILD b/community/plasma-dialer/APKBUILD
index 2d09a184ff..83d24682a7 100644
--- a/community/plasma-dialer/APKBUILD
+++ b/community/plasma-dialer/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="A dialer for Plasma Mobile"
# armhf blocked by extra-cmake-modules
# s390x and mips64 blocked by oxygen-sounds
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://invent.kde.org/plasma-mobile/plasma-dialer"
license="GPL-2.0-or-later"
depends="
diff --git a/community/plasma/APKBUILD b/community/plasma/APKBUILD
index 2c693622f4..adfb55ef9a 100644
--- a/community/plasma/APKBUILD
+++ b/community/plasma/APKBUILD
@@ -5,7 +5,8 @@ pkgver=5.22.2.1
pkgrel=0
pkgdesc="Plasma (Base) meta package"
url="https://kde.org/plasma-desktop"
-arch="noarch !s390x !ppc64le !armhf !mips !mips64" # Limited by kdeplasma-addons -> qt5-qtwebengine armhf: qtdeclarative
+# riscv64 disabled due to missing rust in recursive dependency
+arch="noarch !s390x !ppc64le !armhf !mips !mips64 !riscv64" # Limited by kdeplasma-addons -> qt5-qtwebengine armhf: qtdeclarative
options="!check" # No tests for a metapkg
license="GPL-3.0-or-later"
depends="
diff --git a/community/portfolio/APKBUILD b/community/portfolio/APKBUILD
index 57cae71868..8e82e8a9f4 100644
--- a/community/portfolio/APKBUILD
+++ b/community/portfolio/APKBUILD
@@ -5,7 +5,8 @@ pkgver=0.9.10
pkgrel=2
pkgdesc="Minimalist file manager for those who want to use Linux mobile devices"
url="https://github.com/tchx84/Portfolio"
-arch="noarch !s390x !mips64" # no libhandy1 on s390x and mips64
+# riscv64 disabled due to missing rust in recursive dependency
+arch="noarch !s390x !mips64 !riscv64" # no libhandy1 on s390x and mips64
license="GPL-3.0-or-later"
depends="
gtk+3.0
diff --git a/community/postmarketos-ondev/APKBUILD b/community/postmarketos-ondev/APKBUILD
index 1ad05602b6..3d46f8218b 100644
--- a/community/postmarketos-ondev/APKBUILD
+++ b/community/postmarketos-ondev/APKBUILD
@@ -7,7 +7,8 @@ pkgdesc="Calamares based on-device installer"
url="https://postmarketos.org"
# armhf blocked by qt5-qtdeclarative
# ppc64le, s390x and mips64 blocked by calamares
-arch="all !armhf !ppc64le !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
license="GPL-3.0-or-later"
depends="
$pkgname-openrc
diff --git a/community/qqc2-breeze-style/APKBUILD b/community/qqc2-breeze-style/APKBUILD
index 3d6f75bb7e..cb4aa7cf96 100644
--- a/community/qqc2-breeze-style/APKBUILD
+++ b/community/qqc2-breeze-style/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="Breeze inspired QQC2 style"
# armhf blocked by extra-cmake-modules
# s390x and mips64 blocked by kconfigwidgets
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
url="https://www.plasma-mobile.org/"
license="LicenseRef-KDE-Accepted-LGPL AND LicenseRef-KFQF-Accepted-GPL"
depends="kirigami2"
diff --git a/community/rkward/APKBUILD b/community/rkward/APKBUILD
index 68aad03cef..e9898831e9 100644
--- a/community/rkward/APKBUILD
+++ b/community/rkward/APKBUILD
@@ -5,7 +5,8 @@ pkgver=0.7.2
pkgrel=1
# armhf blocked by extra-cmake-modules
# s390x and ppc64le blocked by qt5-qtwebengine
-arch="all !armhf !s390x !ppc64le !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
url="https://rkward.kde.org/"
pkgdesc="Easy extensible and easy-to-use IDE/GUI for R"
license="GPL-2.0-or-later"
diff --git a/community/rocs/APKBUILD b/community/rocs/APKBUILD
index 6abc183307..d50d2ab4cf 100644
--- a/community/rocs/APKBUILD
+++ b/community/rocs/APKBUILD
@@ -5,7 +5,8 @@ pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
# mips, mips64 and s390x blocked by kxmlgui
-arch="all !armhf !mips !mips64 !s390x"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips !mips64 !s390x !riscv64"
url="https://kde.org/applications/education/org.kde.rocs"
pkgdesc="Graph Theory IDE"
license="GPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND GFDL-1.2-only"
diff --git a/community/sddm/APKBUILD b/community/sddm/APKBUILD
index 07e144e9c1..323deb65f0 100644
--- a/community/sddm/APKBUILD
+++ b/community/sddm/APKBUILD
@@ -7,7 +7,8 @@ pkgdesc="Simple Desktop Display Manager"
url="https://github.com/sddm/sddm/"
# armhf blocked by qt5-qtdeclarative
# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !armhf !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !s390x !mips64 !riscv64"
license="GPL-2.0-only"
depends="
dbus-x11
diff --git a/community/seahorse/APKBUILD b/community/seahorse/APKBUILD
index 47f8271d69..7650bdc83d 100644
--- a/community/seahorse/APKBUILD
+++ b/community/seahorse/APKBUILD
@@ -5,7 +5,8 @@ pkgver=40.0
pkgrel=0
pkgdesc="GNOME application for managing PGP keys."
url="https://projects.gnome.org/seahorse/"
-arch="all !s390x !mips !mips64" # limited by libhandy
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # limited by libhandy
license="GPL-2.0-or-later"
depends="openssh dconf gnome-keyring"
makedepends="vala libxml2-utils
diff --git a/community/simple-scan/APKBUILD b/community/simple-scan/APKBUILD
index 85ccce9e6a..e5d426607a 100644
--- a/community/simple-scan/APKBUILD
+++ b/community/simple-scan/APKBUILD
@@ -6,7 +6,8 @@ pkgver=40.1
pkgrel=0
pkgdesc="Simple Scan allows you to get images from a scanner"
url="https://gitlab.gnome.org/GNOME/simple-scan"
-arch="all !s390x !mips64" # polkit
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips64 !riscv64" # polkit
license="GPL-3.0-or-later"
makedepends="sane-dev dconf-dev gtk+3.0-dev colord-dev libgusb-dev vala itstool
libxml2-utils meson libwebp-dev libhandy1-dev"
diff --git a/community/sound-juicer/APKBUILD b/community/sound-juicer/APKBUILD
index a3c011fddf..80d8ecdd08 100644
--- a/community/sound-juicer/APKBUILD
+++ b/community/sound-juicer/APKBUILD
@@ -5,7 +5,8 @@ pkgver=3.38.0
pkgrel=0
pkgdesc="Sound Juicer is a CD ripping tool using GTK+ and GStreamer"
url="https://wiki.gnome.org/Apps/SoundJuicer"
-arch="all !s390x !mips !mips64" # Limited by brasero
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # Limited by brasero
license="GPL-2.0-or-later"
depends="iso-codes gsettings-desktop-schemas gst-plugins-base gst-plugins-good"
makedepends="glib-dev gtk+3.0-dev brasero-dev gstreamer-dev gst-plugins-base-dev
diff --git a/community/step/APKBUILD b/community/step/APKBUILD
index 33d9fddd81..fea6f885d3 100644
--- a/community/step/APKBUILD
+++ b/community/step/APKBUILD
@@ -5,7 +5,8 @@ pkgver=21.04.2
pkgrel=0
# armhf blocked by extra-cmake-modules
# mips, mips64 and s390x blocked by khtml
-arch="all !armhf !mips !mips64 !s390x"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips !mips64 !s390x !riscv64"
url="https://edu.kde.org/step/"
pkgdesc="Interactive Physics Simulator"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/sxmo-utils/APKBUILD b/community/sxmo-utils/APKBUILD
index 1dc9670851..2416ccf272 100644
--- a/community/sxmo-utils/APKBUILD
+++ b/community/sxmo-utils/APKBUILD
@@ -4,7 +4,8 @@ pkgver=1.4.1
pkgrel=3
pkgdesc="Utility scripts, programs, and configs that hold the Sxmo UI environment together"
url="https://git.sr.ht/~mil/sxmo-utils"
-arch="all !s390x !mips64" # limited by modemmanager and networkmanager
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips64 !riscv64" # limited by modemmanager and networkmanager
arch="$arch !ppc64le" # limited by codemadness-frontends
license="MIT"
makedepends="libx11-dev xproto linux-headers"
diff --git a/community/sxmo-xdm-config/APKBUILD b/community/sxmo-xdm-config/APKBUILD
index 950d1fc89c..8cb783cad5 100644
--- a/community/sxmo-xdm-config/APKBUILD
+++ b/community/sxmo-xdm-config/APKBUILD
@@ -5,7 +5,8 @@ pkgrel=0
pkgdesc="X Display Manager configuration for Sxmo; starts with virtual keyboard and launches Sxmo UI"
options="!check" # No testsuite
url="https://git.sr.ht/~mil/sxmo-xdm-config"
-arch="noarch !s390x !mips64 !ppc64le" # blocked by sxmo-utils
+# riscv64 disabled due to missing rust in recursive dependency
+arch="noarch !s390x !mips64 !ppc64le !riscv64" # blocked by sxmo-utils
license="MIT"
depends="sxmo-utils svkbd xdm"
replaces="sxmo-xdm xdm xdm-openrc"
diff --git a/community/telepathy-ofono/APKBUILD b/community/telepathy-ofono/APKBUILD
index 031485fb1a..e6caa42709 100644
--- a/community/telepathy-ofono/APKBUILD
+++ b/community/telepathy-ofono/APKBUILD
@@ -7,7 +7,8 @@ _commit="b9bfed49157fd16c4a3dc84d29bdc5656beba5c9"
pkgdesc="Telepathy oFono connection manager"
url="https://github.com/TelepathyIM/telepathy-ofono"
# s390x and mips64 blocked by telepathy-mission-control-dev
-arch="all !s390x !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips64 !riscv64"
license="LGPL-2.1-or-later"
depends="ofono"
makedepends="
diff --git a/community/tootle/APKBUILD b/community/tootle/APKBUILD
index fa6db8e854..a4681e7781 100644
--- a/community/tootle/APKBUILD
+++ b/community/tootle/APKBUILD
@@ -5,7 +5,8 @@ pkgver=1.0
pkgrel=0
pkgdesc="Simple Mastodon client for Linux"
url="https://github.com/bleakgrey/tootle"
-arch="all !s390x !mips !mips64" # no libhandy
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !mips !mips64 !riscv64" # no libhandy
license="GPL-3.0-or-later"
makedepends="
glib-dev
diff --git a/community/umbrello/APKBUILD b/community/umbrello/APKBUILD
index c5f3b82e6a..618535a01a 100644
--- a/community/umbrello/APKBUILD
+++ b/community/umbrello/APKBUILD
@@ -3,7 +3,8 @@
pkgname=umbrello
pkgver=21.04.2
pkgrel=0
-arch="all !armhf !mips !mips64 !s390x" # Blocked by extra-cmake-modules, qt5-qtwebkit and rust
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !armhf !mips !mips64 !s390x !riscv64" # Blocked by extra-cmake-modules, qt5-qtwebkit and rust
url="https://umbrello.kde.org/"
pkgdesc="GUI for diagramming Unified Modelling Language (UML)"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/urfkill/APKBUILD b/community/urfkill/APKBUILD
index 5fe5502f00..350cd4267c 100644
--- a/community/urfkill/APKBUILD
+++ b/community/urfkill/APKBUILD
@@ -5,7 +5,8 @@ pkgrel=1
_commit="333a29d5d7b09c4ae296ec37d9c6aaaf1b8f539b"
pkgdesc="Handle rfkill events in userspace"
url="https://freedesktop.org/wiki/Software/urfkill/"
-arch="all !mips !mips64 !s390x" # blocked by polkit-elogind-dev
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !mips !mips64 !s390x !riscv64" # blocked by polkit-elogind-dev
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends_dev="
dbus-glib-dev
diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index ffc7457ec6..13f3ddbf0d 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -7,7 +7,8 @@ _libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
pkgdesc="The reference Wayland server"
url="https://wayland.freedesktop.org/"
-arch="all !s390x !ppc64le !mips64"
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !s390x !ppc64le !mips64 !riscv64"
license="MIT"
makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
libinput-dev libunwind-dev mtdev-dev libxcursor-dev glu-dev
diff --git a/community/xdg-desktop-portal-gtk/APKBUILD b/community/xdg-desktop-portal-gtk/APKBUILD
index 404352f813..2c78c5c6a3 100644
--- a/community/xdg-desktop-portal-gtk/APKBUILD
+++ b/community/xdg-desktop-portal-gtk/APKBUILD
@@ -5,7 +5,8 @@ pkgver=1.8.0
pkgrel=0
pkgdesc="Gtk implementation of xdg-desktop-portal"
url="https://github.com/flatpak/xdg-desktop-portal-gtk"
-arch="all !mips !mips64 !s390x" # xdg-desktop-portal->flatpak->polkit
+# riscv64 disabled due to missing rust in recursive dependency
+arch="all !mips !mips64 !s390x !riscv64" # xdg-desktop-portal->flatpak->polkit
license="LGPL-2.1-or-later"
depends="xdg-desktop-portal"
makedepends="gtk+3.0-dev dbus-dev gnome-desktop-dev"