aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 13:29:08 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 17:38:08 -0300
commita797221d60591d3304026af4a569f4df487fda61 (patch)
treefd50772c514659162230a14ed3d76578e3da290d
parent102b50ede88dbce8b53c18f69e290edb4caf2cae (diff)
community/perl-io-prompt-tiny: fix URL&License
* modernize
-rw-r--r--community/perl-io-prompt-tiny/APKBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/community/perl-io-prompt-tiny/APKBUILD b/community/perl-io-prompt-tiny/APKBUILD
index 5836f7966fa..f6761d5c383 100644
--- a/community/perl-io-prompt-tiny/APKBUILD
+++ b/community/perl-io-prompt-tiny/APKBUILD
@@ -4,43 +4,35 @@
pkgname=perl-io-prompt-tiny
_pkgreal=IO-Prompt-Tiny
pkgver=0.003
-pkgrel=0
+pkgrel=1
pkgdesc="Prompt for user input with a default option"
-url="http://search.cpan.org/dist/IO-Prompt-Tiny/"
+url="https://metacpan.org/pod/IO::Prompt::Tiny"
arch="noarch"
license="Apache-2.0"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends="perl-capture-tiny"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+depends="perl"
+makedepends="perl-dev perl-capture-tiny"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}