aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-30 12:33:19 +0200
committerprspkt <prspkt@protonmail.com>2019-03-30 12:33:19 +0200
commita841ebc9d5a994f6cd19feee1bd34d497223e0e4 (patch)
tree916edce3913613037c5eaa58da470ea8b3ec1fae
parent3114773192f1ba690433e9b172a720f047970b5b (diff)
testing/py3-uptime: clarify license, modernize
-rw-r--r--testing/py3-uptime/APKBUILD27
1 files changed, 6 insertions, 21 deletions
diff --git a/testing/py3-uptime/APKBUILD b/testing/py3-uptime/APKBUILD
index e9599174c31..4f0fcf674c5 100644
--- a/testing/py3-uptime/APKBUILD
+++ b/testing/py3-uptime/APKBUILD
@@ -7,37 +7,22 @@ pkgrel=0
pkgdesc="A Python uptime library"
url="https://github.com/Cairnarvon/uptime"
arch="all"
-license="BSD"
+license="BSD-2-Clause"
provides="py-uptime" # for backwards compatibility
replaces="py-uptime=$pkgver-r$pkgrel" # for backwards compatibility
depends="python3"
-depends_dev=""
makedepends="python3-dev py3-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python3 setup.py build || return 1
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="046063e97abbee37bf8de3fd16df674d uptime-3.0.1.tar.gz"
-sha256sums="7c300254775b807ce46e3dcbcda30aa3b9a204b9c57a7ac1e79ee6dbe3942973 uptime-3.0.1.tar.gz"
sha512sums="55df1c30aa4be3e873ad36d0f784d49bc127d2bd38041c1453b112474dd52033e55d277172d8fdd73b3fabc7bf5071f29329d2a828244ef420d2da7db0f49a54 uptime-3.0.1.tar.gz"