aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-05-06 22:07:09 +0200
committeralice <alice@ayaya.dev>2023-05-06 20:12:34 +0000
commita869719f7dfa4db596ee9398f2730d7bca11c122 (patch)
tree0f4d754cad26c5fffb2ac97433ecfa898f71aa5f
parentf65f431d577df4bccd2bc53adc576100e068119d (diff)
community/py3-send2trash: upgrade to 1.8.2
-rw-r--r--community/py3-send2trash/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/py3-send2trash/APKBUILD b/community/py3-send2trash/APKBUILD
index 7e829d66f01..aa4fc82763a 100644
--- a/community/py3-send2trash/APKBUILD
+++ b/community/py3-send2trash/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
pkgname=py3-send2trash
-pkgver=1.8.0
-pkgrel=4
+pkgver=1.8.2
+pkgrel=0
pkgdesc="Send file to trash natively"
url="https://github.com/arsenetar/send2trash"
arch="noarch"
license="BSD-3-Clause"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-installer py3-wheel"
checkdepends="py3-pytest"
subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/arsenetar/send2trash/archive/refs/tags/$pkgver.tar.gz"
builddir="$srcdir/"send2trash-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -22,9 +24,10 @@ check() {
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ dist/Send2Trash*.whl
}
sha512sums="
-9dc15fbd262eb5a05a355b436c0e582e5ef9b484f859b53faafe6af5bd08ef88b9aa5121485c2fffb7dbe5aeeef29f6719035e08c61da273fd4fa51383b062fe py3-send2trash-1.8.0.tar.gz
+b750ef75ee7650dd5a7fe3aa18c71e5f812e9b6b238fd80556c1569ba0a5797b1634e53953b5dad6363a224e61cac4a10f6c1b30050228f531015b7fb3d234a1 py3-send2trash-1.8.2.tar.gz
"