aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2022-09-27 00:51:36 +0200
committeralice <alice@ayaya.dev>2022-09-26 23:19:56 +0000
commita8c22ce032cff83a114a209eb0a340a837110fdb (patch)
tree4be6c8cd8327b740a7a950cf715a08f171e0198d
parent262e25517f62c531e51f1a8dcf9da38d83930a44 (diff)
main/py3-coverage: add apk instructions to missing py3-toml error message
-rw-r--r--main/py3-coverage/APKBUILD7
-rw-r--r--main/py3-coverage/toml-error-message.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/main/py3-coverage/APKBUILD b/main/py3-coverage/APKBUILD
index ea2d367955e..8aa017687ab 100644
--- a/main/py3-coverage/APKBUILD
+++ b/main/py3-coverage/APKBUILD
@@ -2,14 +2,16 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-coverage
pkgver=5.5
-pkgrel=1
+pkgrel=2
pkgdesc="Code coverage measurement for Python"
options="!check" # Requires unpackaged 'flaky'
url="https://pypi.python.org/pypi/coverage"
arch="all"
license="Apache-2.0"
makedepends="python3-dev py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/c/coverage/coverage-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/c/coverage/coverage-$pkgver.tar.gz
+ toml-error-message.patch
+ "
builddir="$srcdir/coverage-$pkgver"
replaces="py-coverage" # Backwards compatibility
@@ -28,4 +30,5 @@ package() {
}
sha512sums="
fb78b4920a2f18afb9545a6f13910f491708443965881954fff6ee8553ab3d6bd898f7a95df1091435e8d5627ac850b880a6233e716a6acb934ecc195ec2ee52 coverage-5.5.tar.gz
+c78e5f118e58b1894e4bfe476fef03745ae8e35338965183f168005b56397f0c683ade9618726ce6d5e9e6c2bc4b888a6a1afce80a764658ad290f0ad34e5a36 toml-error-message.patch
"
diff --git a/main/py3-coverage/toml-error-message.patch b/main/py3-coverage/toml-error-message.patch
new file mode 100644
index 00000000000..92cf6580055
--- /dev/null
+++ b/main/py3-coverage/toml-error-message.patch
@@ -0,0 +1,13 @@
+diff --git a/coverage/tomlconfig.py b/coverage/tomlconfig.py
+index 3ad5815..931192d 100644
+--- a/coverage/tomlconfig.py
++++ b/coverage/tomlconfig.py
+@@ -58,7 +58,7 @@ class TomlConfigParser:
+ has_toml = re.search(r"^\[tool\.coverage\.", toml_text, flags=re.MULTILINE)
+ if self.our_file or has_toml:
+ # Looks like they meant to read TOML, but we can't read it.
+- msg = "Can't read {!r} without TOML support. Install with [toml] extra"
++ msg = "Can't read {!r} without TOML support. Install with `apk add py3-toml` or [toml] extra"
+ raise CoverageException(msg.format(filename))
+ return []
+