aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-06-27 21:04:37 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2021-06-27 21:04:37 +0200
commita8f21ed06eb409b957f37c0c2db231479ce33bc6 (patch)
tree658632d4f059f60d572a51e2008beb267ead48f8
parent6c4c8cfeb062367f343e69b535b911c14689a959 (diff)
community/xdm: Remove /usr/ucb from system/user path
Since f440e2db3f139f3e1b611e1f964acfcc93890fcf, /etc/profile appends to $PATH instead of overwriting it. The default PATH used by xdm includes /usr/ucb which we don't use on Alpine. Since /etc/profile no longer overwrites $PATH, /usr/ucb will be included in the users $PATH variable unless it's explicitly overwritten by the users configuration, even though Alpine doesn't have that directory.
-rw-r--r--community/xdm/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/xdm/APKBUILD b/community/xdm/APKBUILD
index 50dd8772784..f800748e0e8 100644
--- a/community/xdm/APKBUILD
+++ b/community/xdm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
pkgname=xdm
pkgver=1.1.12
-pkgrel=4
+pkgrel=5
pkgdesc="X Display Manager"
options="!check" # No testsuite
url="http://xorg.freedesktop.org/"
@@ -24,6 +24,11 @@ source="
"
build() {
+ # Use more sensible system/user path values.
+ # The default includes /usr/ucb, which Alpine doesn't use.
+ export DEF_SYSTEM_PATH=/usr/local/bin:/usr/bin:/bin
+ export DEF_USER_PATH=/usr/local/bin:/usr/bin:/bin
+
./configure \
--prefix=/usr \
--sysconfdir=/etc \