aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-05-21 12:31:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-21 12:31:58 +0000
commita979093424e0b9047cb8c75a64ab8c9d1c3aeb72 (patch)
tree14a3435c8f64df9c1f8437bf42c7e681ae6d643f
parent0e8d7ba30c4df235c7366134f114acaf56f45042 (diff)
main/cython: run tests in parallel
run the tests in parallel. This makes the build run in 20 mins instead of 2 hours. Also reduce the verbosity of running the tests. The parallelization makes the output confusing anyway.
-rw-r--r--main/cython/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/cython/APKBUILD b/main/cython/APKBUILD
index b6b6a41127f..503d53cb330 100644
--- a/main/cython/APKBUILD
+++ b/main/cython/APKBUILD
@@ -21,7 +21,7 @@ build() {
}
check() {
- PYTHON=python3 make test
+ python3 runtests.py -j${JOBS:-$(nproc)}
}
package() {