aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-03-21 09:42:17 +0100
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-26 06:27:37 +0000
commitaa251917a923821de5ed0a20dabdb1a44f2adc00 (patch)
tree4863241be8e5f73ad28a63614873bda1835bef66
parentd8f9f150c47c5ef1e9b5c8025a1330d4cbcf9a58 (diff)
main/libseccomp: security upgrade to 2.4.0
-rw-r--r--main/libseccomp/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/main/libseccomp/APKBUILD b/main/libseccomp/APKBUILD
index f6eddb18f7b..c04bccf6c87 100644
--- a/main/libseccomp/APKBUILD
+++ b/main/libseccomp/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Contributor: Dan Williams <dan@ma.ssive.co>
pkgname=libseccomp
-pkgver=2.3.3
-pkgrel=1
+pkgver=2.4.0
+pkgrel=0
pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
url="https://github.com/seccomp/libseccomp"
arch="all"
@@ -16,6 +16,10 @@ source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libsecc
remove-redefinition-prctl.patch"
builddir="$srcdir/libseccomp-$pkgver"
+# secfixes:
+# 2.4.0-r0:
+# - CVE-2019-9893
+
build() {
cd "$builddir"
./configure \
@@ -25,20 +29,19 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
check() {
cd "$builddir"
- make check || return 1
+ make check
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="845c7e0e916b5f5ad74da446ceff3250148b745c909185f6d5059e807d1b42fa6b74f356cce2a396bff0d4c7a3120e7cdad98d490a97d549327c7693fe1918be libseccomp-2.3.3.tar.gz
+sha512sums="daa4a32c6c2b2f39aa9db1a4606619f9faeffcd2fca00c25ac5cf95d0405639ec21203293be7c8341317a05b18fd9f603a201544457cac91bf034a0bbd4dfc88 libseccomp-2.4.0.tar.gz
f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"