aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-04-22 02:36:07 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2021-04-22 02:36:07 +0200
commitac44dde7f02e7eb18d366aafbc98054f8565c18f (patch)
tree63df34968587d38a8f96cf73a0ca6e63854b804e
parente5733f1b87cb170d4ed59921c71e8e316a515507 (diff)
community/radare2: upgrade to 5.2.1
-rw-r--r--community/radare2/0001-state.c-fix-with-openssl-build.patch51
-rw-r--r--community/radare2/APKBUILD10
2 files changed, 4 insertions, 57 deletions
diff --git a/community/radare2/0001-state.c-fix-with-openssl-build.patch b/community/radare2/0001-state.c-fix-with-openssl-build.patch
deleted file mode 100644
index ad1fcf63c79..00000000000
--- a/community/radare2/0001-state.c-fix-with-openssl-build.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From e5e7469b6450c374e0884d35d44824e1a4eb46b4 Mon Sep 17 00:00:00 2001
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Mon, 12 Apr 2021 23:48:09 +0100
-Subject: [PATCH] state.c: fix --with-openssl build
-
-Build failure happens at:
-
-```
-$ ./configure --with-openssl && make
-....
-state.c: In function 'r_hash_do_hmac_sha256':
-state.c:155:19: error: 'r_SHA256_BLOCK_LENGTH' undeclared (first use in this function); did you mean 'SHA256_BLOCK_LENGTH'?
- 155 | ut8 bskey[r_SHA256_BLOCK_LENGTH]; // block-sized key
- | ^~~~~~~~~~~~~~~~~~~~~
- | SHA256_BLOCK_LENGTH
-```
-
-The change defines r2_.* aliases for openssl implementation.
----
- libr/hash/state.c | 18 ++++++++++++++++++
- 1 file changed, 18 insertions(+)
-
-diff --git a/libr/hash/state.c b/libr/hash/state.c
-index 6f3ae6b4c..93adafc81 100644
---- a/libr/hash/state.c
-+++ b/libr/hash/state.c
-@@ -7,6 +7,24 @@
- #include <openssl/md4.h>
- #include <openssl/md5.h>
- #include <openssl/sha.h>
-+
-+# define r_SHA256_BLOCK_LENGTH SHA256_BLOCK_LENGTH
-+
-+# define r_SHA1_Init SHA1_Init
-+# define r_SHA1_Update SHA1_Update
-+# define r_SHA1_Final SHA1_Final
-+
-+# define r_SHA256_Init SHA256_Init
-+# define r_SHA256_Update SHA256_Update
-+# define r_SHA256_Final SHA256_Final
-+
-+# define r_SHA384_Init SHA384_Init
-+# define r_SHA384_Update SHA384_Update
-+# define r_SHA384_Final SHA384_Final
-+
-+# define r_SHA512_Init SHA512_Init
-+# define r_SHA512_Update SHA512_Update
-+# define r_SHA512_Final SHA512_Final
- #else
- #include "md4.h"
- #include "md5.h"
diff --git a/community/radare2/APKBUILD b/community/radare2/APKBUILD
index 0c8c23fbaec..fce107e5d2e 100644
--- a/community/radare2/APKBUILD
+++ b/community/radare2/APKBUILD
@@ -4,7 +4,7 @@
# Contributor: Jose-Luis Rivas <ghostbar@riseup.net>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=radare2
-pkgver=5.2.0
+pkgver=5.2.1
pkgrel=0
pkgdesc="An opensource, crossplatform reverse engineering framework"
url="http://www.radare.org"
@@ -14,8 +14,7 @@ options="!check" # upstream does not provide any working testsuite
makedepends="$depends_dev libzip-dev openssl-dev capstone-dev linux-headers"
subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/radare/radare2/archive/$pkgver.tar.gz
- string-header-build-fix.patch
- 0001-state.c-fix-with-openssl-build.patch"
+ string-header-build-fix.patch"
# secfixes:
# 4.5.0-r0:
@@ -47,6 +46,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="664ea6df65c1ea8d13a80d281c3dbbcae16fb308826b9276e68d63f26f239f4a5c0d59abcf9325c299894ad4ebf1098b964aa3cad0bbe58b6c96cbd6e7b25952 radare2-5.2.0.tar.gz
-5e60a1112a10cdd6a31374ba9b564d6522a37086380cf74b7232e32fb700ae1b2f68edbc0726ebedcc31d4789bc4f89525f117f25dac3609c60a75d471e49c85 string-header-build-fix.patch
-17eb9bf2da838fea8acd08eecfa19ebecdb4aa815e985fc25be522f89d3804a06fbf333ae94616d615d642ed1ce6cbc5091ccf28ef0aa6396868003a05ca7d29 0001-state.c-fix-with-openssl-build.patch"
+sha512sums="c744f5c8fff163022a7a9a913fe34dfa0dee0d9ab3b18bd4cc038c2d487dbfeba2f1523aa12a3166a2c22c45bcc71e802fae101b72fc2e6adab96b522c0de17b radare2-5.2.1.tar.gz
+5e60a1112a10cdd6a31374ba9b564d6522a37086380cf74b7232e32fb700ae1b2f68edbc0726ebedcc31d4789bc4f89525f117f25dac3609c60a75d471e49c85 string-header-build-fix.patch"