aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntoine Fontaine <antoine.fontaine@epfl.ch>2020-05-30 21:17:57 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 17:25:46 +0000
commitac4ba47aa907cdc274b72dac1f954afa1e6a5b8b (patch)
treeb05802463daccabbf66dd429b222be11b850cf57
parent590ddde28a70ec192711a9ad43b39e2b7e305ea1 (diff)
community/py3-peewee: enable tests
this also swap out the source url for upstream because tests are excluded from pypi package.
-rw-r--r--community/py3-peewee/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/py3-peewee/APKBUILD b/community/py3-peewee/APKBUILD
index c0d2185bea0..bdaff9bf8bb 100644
--- a/community/py3-peewee/APKBUILD
+++ b/community/py3-peewee/APKBUILD
@@ -1,16 +1,18 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-peewee
_pkgname=peewee
pkgver=3.13.3
-pkgrel=0
+pkgrel=1
pkgdesc="Small, expressive ORM"
url="https://github.com/coleifer/peewee"
arch="all"
license="MIT"
depends="python3"
makedepends="cython py3-setuptools python3-dev sqlite-dev"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+checkdepends="py3-psycopg2"
+source="py3-peewee-$pkgver.tar.gz::https://github.com/coleifer/peewee/archive/$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
@@ -18,8 +20,12 @@ build() {
python3 setup.py build
}
+check() {
+ python3 runtests.py
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="829bea39366d0ebeef19a8c169ac7ad724496770411549baddff33a82f2962c026a34bfce2ed7b6eb08527311504516467c49918a91de5fd670dd871b5ec4447 peewee-3.13.3.tar.gz"
+sha512sums="e7df0b07092d96c9e4a4d5d4eb21b0bee14f133576c90cf518add5c59b1655d79677b29f5577a2d34d06c3f89b300f03da4529a2ad75c4ca9037244f66b15151 py3-peewee-3.13.3.tar.gz"