aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-11 20:44:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-18 09:13:59 +0000
commitacc8d8098c2706b456f26989363525a38a88d5a6 (patch)
tree985b8f4b9af90b6ede33a01b4756bae77f6bbea7
parent250db8ab8ad6704202512decc56d08a03ce1809e (diff)
main/portaudio: enable cpp bindings, split them into libportaudiocxx
-rw-r--r--main/portaudio/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/main/portaudio/APKBUILD b/main/portaudio/APKBUILD
index 8e84c3bb86e..2a51128bd99 100644
--- a/main/portaudio/APKBUILD
+++ b/main/portaudio/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=portaudio
pkgver=190600.20161030
-pkgrel=0
+pkgrel=1
pkgdesc="Cross platform, open-source, audio I/O library"
url="http://www.portaudio.com/"
arch="all"
@@ -11,7 +11,7 @@ license="MIT"
options="!check" # No unit tests, requires hardware to execute tests
makedepends="alsa-lib-dev jack-dev linux-headers autoconf automake libtool"
checkdepends="jack alsa-lib"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev libportaudiocxx:_cxx"
source="http://www.portaudio.com/archives/pa_stable_v${pkgver/./_}.tgz
portaudio-pkgconfig-alsa.patch
portaudio-audacity.patch
@@ -22,7 +22,10 @@ prepare() {
cd "$builddir"
update_config_sub
default_prepare
- autoreconf -vif
+ autoreconf -if
+ cd bindings/cpp
+ update_config_sub
+ autoreconf -if
}
build() {
@@ -33,8 +36,10 @@ build() {
--prefix=/usr \
--disable-static \
--with-jack \
- --with-alsa
- make
+ --with-alsa \
+ --enable-cxx
+ # race conditions in build cause build failures otherwise
+ make -j1
}
check() {
@@ -63,6 +68,12 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
+_cxx() {
+ pkgdesc="C++ bindings library for portaudio"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libportaudiocpp* "$subpkgdir"/usr/lib
+}
+
sha512sums="7ec692cbd8c23878b029fad9d9fd63a021f57e60c4921f602995a2fca070c29f17a280c7f2da5966c4aad29d28434538452f4c822eacf3a60af59a6dc8e9704c pa_stable_v190600_20161030.tgz
d58e7f8717f9d451535546e16939a959f63ccdd21bcbbc8e08efde2722382b068603bae6d93449476b206c85160d8084d39b39748b4fb43ab2b6eaee704ba1f8 portaudio-pkgconfig-alsa.patch
e5a83dedadd8d66d24efc5062f339b2518dd707ccb856235f2beb6bb0f78a61b5439b708e52a64a62a02b5e55f97eaa8644b5f057b582d542730a42a5b731571 portaudio-audacity.patch"