aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2020-04-13 00:50:11 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-04-14 00:57:29 +0000
commitaceeedea27c36b0a60d5d6f3290b2dffc4f4a530 (patch)
tree289d7a728a5eeeb358a6a9d6b496bd1ac6700f44
parentea18b884759dc9123bb179f3c5117b94a6fd856c (diff)
community/pcmanfm: switch to gtk3
-rw-r--r--community/libfm/APKBUILD6
-rw-r--r--community/pcmanfm/APKBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index 9808dcb1d59..2bcd0260230 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libfm
pkgver=1.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
@@ -12,7 +12,7 @@ makedepends="
autoconf
automake
dbus-glib-dev
- gtk+2.0-dev
+ gtk+3.0-dev
gtk-doc
intltool
libexif-dev
@@ -38,7 +38,9 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--enable-udisks \
+ --with-gtk=3 \
--with-gnu-ld
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
diff --git a/community/pcmanfm/APKBUILD b/community/pcmanfm/APKBUILD
index abc5fa43d02..f916f7aff35 100644
--- a/community/pcmanfm/APKBUILD
+++ b/community/pcmanfm/APKBUILD
@@ -3,12 +3,12 @@
pkgname=pcmanfm
pkgver=1.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Extremely fast and lightweight file manager"
arch="all"
url="https://wiki.lxde.org/en/PCManFM"
license="GPL-2.0-or-later"
-makedepends="gtk+2.0-dev libfm-dev intltool"
+makedepends="gtk+3.0-dev libfm-dev intltool"
subpackages="$pkgname-doc $pkgname-lang"
source="
https://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz
@@ -23,7 +23,8 @@ build() {
./configure \
--sysconfdir=/etc \
- --prefix=/usr
+ --prefix=/usr \
+ --with-gtk=3
make
}