aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-15 06:18:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-15 06:18:24 -0300
commitadb33ff0ebcb61be9992fe4bd7c7fca2888f9214 (patch)
tree6b88da3ffec5bf8e570e1c5cbb6e8743b368ec06
parent8b59d8adeea80a263d8552b574612c27cfe0ac1f (diff)
testing/simgear: fix build with boost >= 1.73.0
-rw-r--r--testing/simgear/APKBUILD2
-rw-r--r--testing/simgear/boost-1.73.0.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/testing/simgear/APKBUILD b/testing/simgear/APKBUILD
index f906dce1cce..1daefe9ca86 100644
--- a/testing/simgear/APKBUILD
+++ b/testing/simgear/APKBUILD
@@ -12,6 +12,7 @@ makedepends="$depends_dev boost-dev cmake curl-dev mesa-dev openal-soft-dev
subpackages="$pkgname-dev"
source="https://downloads.sourceforge.net/project/flightgear/release-${pkgver%.[0-9]}/simgear-$pkgver.tar.bz2
musl-fixes.patch
+ boost-1.73.0.patch
https://github.com/FlightGear/simgear/commit/d883ab278d10c89580d5bbc4473d2e9fc375b7b9.patch
https://github.com/FlightGear/simgear/commit/b28f030874d514dfc1393f5a7156f202556f3730.patch
https://github.com/FlightGear/simgear/commit/dc886118baec64f9e86e45c1e2713bbf245f972e.patch
@@ -37,6 +38,7 @@ package() {
sha512sums="83fe4330cf27b9298719f53f2fccde2af77bacdc6f430cc22c8bdfb475fe9b6e01578c1225af21e4e1433c7d2f2b00427454064f942359ba4c1e9896e7fe05d2 simgear-2019.1.1.tar.bz2
7efcf01c9328b0732ae9aa7af4edb52e14919663a8d3acbe429a0697f59a55e85a71628d9afaa3d38327d960dbf5dacc1f964e38dd6cb499b593ae2be918b140 musl-fixes.patch
+48e96794b2ad370942fd5534d3c5a3e5a642f04d9c7bfb96cf391b03ee9c6148927f6b83a37da539c71a34bdcfd40b5a0048d49fb3291863de3ee191892c0b93 boost-1.73.0.patch
db2e5a38ff985ac9d81af6d623a92bd1791d002b8629a810eb7873d5b743e6a51f5c841d3ba5207f95d6edcf3fe2565ec521f9d86ef6eb1f4a5c61dc90de5bdb d883ab278d10c89580d5bbc4473d2e9fc375b7b9.patch
54b40b272b6847c6bd1c74d2758b15c239870c590daa6fdeb6eb402e220a0606a06f7f9e5abfebc3d8856d79e6921c0ec641cae148bac3efb0972150b7323f3d b28f030874d514dfc1393f5a7156f202556f3730.patch
d03427c942b377d147529fb29f71e307543dd19946ef21868629d20c1e7205a122bebf8d7d54c4914e6b1765eceab207e433501db4665f6657d18e56a7bf80ea dc886118baec64f9e86e45c1e2713bbf245f972e.patch"
diff --git a/testing/simgear/boost-1.73.0.patch b/testing/simgear/boost-1.73.0.patch
new file mode 100644
index 00000000000..2868286376f
--- /dev/null
+++ b/testing/simgear/boost-1.73.0.patch
@@ -0,0 +1,13 @@
+Taken from Gentoo
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -227,7 +227,7 @@
+ endif()
+
+ find_package(Boost REQUIRED)
+-set (BOOST_CXX_FLAGS "-DBOOST_BIMAP_DISABLE_SERIALIZATION")
++set (BOOST_CXX_FLAGS "-DBOOST_BIMAP_DISABLE_SERIALIZATION -DBOOST_NO_STDLIB_CONFIG")
+ include(BoostTestTargets)
+
+ if(SIMGEAR_HEADLESS)