aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNewbyte <newbie13xd@gmail.com>2022-04-10 18:27:33 +0200
committeralice <alice@ayaya.dev>2022-04-13 13:40:41 +0000
commitadd7addae6b3a3bc4d77a24995b88d6fee927f30 (patch)
treea244093219251b498f8077793ac44b7e1256fc12
parent8fa0ba3b143d31386874b08163de18a15e8af76e (diff)
community/gnome-screenshot: upgrade to 41.0
-rw-r--r--community/gnome-screenshot/APKBUILD11
-rw-r--r--community/gnome-screenshot/fix-build-with-meson-0.60.0.patch36
2 files changed, 44 insertions, 3 deletions
diff --git a/community/gnome-screenshot/APKBUILD b/community/gnome-screenshot/APKBUILD
index aa233d24d23..031d3da27d6 100644
--- a/community/gnome-screenshot/APKBUILD
+++ b/community/gnome-screenshot/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-screenshot
-pkgver=40.0
+pkgver=41.0
pkgrel=0
pkgdesc="Screenshot capture utility for GNOME"
url="https://gitlab.gnome.org/GNOME/gnome-screenshot"
@@ -12,7 +12,9 @@ depends="desktop-file-utils"
makedepends="meson libcanberra-dev glib-dev itstool appstream-glib-dev
libhandy1-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gnome-screenshot/${pkgver%.*}/gnome-screenshot-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-screenshot/${pkgver%.*}/gnome-screenshot-$pkgver.tar.xz
+ fix-build-with-meson-0.60.0.patch
+ "
build() {
abuild-meson . output
@@ -27,4 +29,7 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="0889d7701711f17de68f8a55f512b7764fed087b1b2f86b372d1a38ee956f05ca8c833ca16a1de2396b07c01de79204d988192036780f521b82733436d019cb0 gnome-screenshot-40.0.tar.xz"
+sha512sums="
+ab6c7e22cbca2739844707e59329ecd67901e04f968bd0b20a07dffff825e9772697ebf20a1ab2a920fa839ea40d0bd872d17db2b4cb7856a6f8ee4ec1426d19 gnome-screenshot-41.0.tar.xz
+314fe977317b143d36796ab722bbd6f55083448b9737bb838ab21916c05db79925e337a7a84761dc270764b742bbef2d74600d349cd4182fcd787982db59ef1b fix-build-with-meson-0.60.0.patch
+"
diff --git a/community/gnome-screenshot/fix-build-with-meson-0.60.0.patch b/community/gnome-screenshot/fix-build-with-meson-0.60.0.patch
new file mode 100644
index 00000000000..b21aa0490d4
--- /dev/null
+++ b/community/gnome-screenshot/fix-build-with-meson-0.60.0.patch
@@ -0,0 +1,36 @@
+From b60dad3c2536c17bd201f74ad8e40eb74385ed9f Mon Sep 17 00:00:00 2001
+From: Jack Hill <jackhill@jackhill.us>
+Date: Thu, 18 Nov 2021 00:46:58 -0500
+Subject: [PATCH] meson: remove extraneous positional argument
+
+* data/meson.build (desktop_file)
+ (metainfo_file): Remove extraneous positional argument.
+
+Closes #186
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index fd570b3..4e2e2e8 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,7 +1,6 @@
+ gnome = import('gnome')
+
+ desktop_file = i18n.merge_file(
+- 'desktop',
+ type: 'desktop',
+ input: 'org.gnome.Screenshot.desktop.in',
+ output: 'org.gnome.Screenshot.desktop',
+@@ -23,7 +22,6 @@ if desktop_file_validate.found()
+ endif
+
+ metainfo_file = i18n.merge_file(
+- 'appdata',
+ input: 'org.gnome.Screenshot.metainfo.xml.in',
+ output: 'org.gnome.Screenshot.metainfo.xml',
+ po_dir: join_paths(meson.current_source_dir(), '../po'),
+--
+GitLab
+