aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Dunham <ibid.ag@gmail.com>2014-09-12 21:07:46 -0700
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-15 08:52:13 +0000
commitae6a9d44e890cd846cd3e9c0edc5b2a239c75e3c (patch)
treea73b5543749796dc4405bbe20a3bb24167301933
parent36ad796225e9072c4f94de3ff6389e74ec02b3f0 (diff)
unmaintained/vpnc: fix build
move error.h into #ifdef __GLIBC__ rather than __linux__||__GLIBC__ hack: comment out a header that breaks the build on musl
-rw-r--r--unmaintained/vpnc/APKBUILD10
-rw-r--r--unmaintained/vpnc/working.patch32
2 files changed, 42 insertions, 0 deletions
diff --git a/unmaintained/vpnc/APKBUILD b/unmaintained/vpnc/APKBUILD
index 15857b50f8a..80781818784 100644
--- a/unmaintained/vpnc/APKBUILD
+++ b/unmaintained/vpnc/APKBUILD
@@ -12,6 +12,7 @@ makedepends="libgcrypt-dev perl"
install=""
subpackages="$pkgname-doc"
source="http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-$pkgver.tar.gz
+ working.patch
vpnc.initd
vpnc.confd"
@@ -41,5 +42,14 @@ package() {
}
md5sums="4378f9551d5b077e1770bbe09995afb3 vpnc-0.5.3.tar.gz
+b140eec1e05a91fefbf0dad7cfdc7c4c working.patch
481ddc83b829de62f459f9b94e0c334b vpnc.initd
5c9fe863f70cc5262c095012b4bcc163 vpnc.confd"
+sha256sums="46cea3bd02f207c62c7c6f2f22133382602baeda1dc320747809e94881414884 vpnc-0.5.3.tar.gz
+1085f41ba75cbc5e281c6a11724c56fb0d9f844488ab13b40b067e32af98d263 working.patch
+aa423cd0a52183e0bdec8b599d52555e4f5c22573cee68bd6b25ff42be129fa5 vpnc.initd
+89a14f4d11b7fb156dd823e5d2c15edd0d5ca649bd16460ef6350cfe728b4a88 vpnc.confd"
+sha512sums="fd1251d200c3826ebfd7022683e38912f30c2a95fbc51259bcd1fdf0570ef3c53cd842003c117a770657f7f8ebb00ceffeea91ced0c3f83dd9c1ca0488519ea3 vpnc-0.5.3.tar.gz
+6c3eb976d3877b02c751c310f835bc864e4868d167bbaf9f365b9b728d732cc018591e9a8dfc5a4277b01daf070b74f3bb7e67e175b90ee495fecec1a049e29f working.patch
+5dbd83a06608714adf5ae5f021a7142c26cdd94fcd89591b029861cf87efdd4fcb783eb1365ad8fcc3edc915c3d2ddb32921662f9c2540994a54972847fa4781 vpnc.initd
+1254f687dcd9822becfcccabbb34d8343d715d70247dbf4b5e018835fff24b33f5272368f77199d697c8d11d913182b1f756d5e08a46b2057849779f09b19633 vpnc.confd"
diff --git a/unmaintained/vpnc/working.patch b/unmaintained/vpnc/working.patch
new file mode 100644
index 00000000000..2a6e1a19a2f
--- /dev/null
+++ b/unmaintained/vpnc/working.patch
@@ -0,0 +1,32 @@
+diff --git a/sysdep.c b/sysdep.c
+index ff07753..43fdb74 100644
+--- a/sysdep.c
++++ b/sysdep.c
+@@ -59,7 +59,7 @@
+ #if defined(__DragonFly__)
+ #include <net/tun/if_tun.h>
+ #elif defined(__linux__)
+-#include <linux/if_tun.h>
++/*#include <linux/if_tun.h>*/
+ #elif defined(__APPLE__)
+ /* no header for tun */
+ #elif defined(__CYGWIN__)
+diff --git a/sysdep.h b/sysdep.h
+index a5eafd6..af34e94 100644
+--- a/sysdep.h
++++ b/sysdep.h
+@@ -38,11 +38,13 @@ int tun_get_hwaddr(int fd, char *dev, uint8_t *hwaddr);
+
+ /***************************************************************************/
+ #if defined(__linux__) || defined(__GLIBC__)
++#ifdef __GLIBC__
+ #include <error.h>
++#define HAVE_ERROR 1
++#endif
+
+ #define HAVE_VASPRINTF 1
+ #define HAVE_ASPRINTF 1
+-#define HAVE_ERROR 1
+ #define HAVE_GETLINE 1
+ #define HAVE_UNSETENV 1
+ #define HAVE_SETENV 1