aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-02-08 04:49:11 +0000
committerpsykose <alice@ayaya.dev>2023-02-08 05:49:11 +0100
commitb1b9ca2e4e443f2914c48ffbc6844aa29a98528b (patch)
treeaec6088f704e9545ab5ab580922ed08ccdb5aeff
parent6c7fb48f2f97019ea093a7a5785ea6cbe45c1a11 (diff)
downloadaports-b1b9ca2e4e443f2914c48ffbc6844aa29a98528b.tar.gz
aports-b1b9ca2e4e443f2914c48ffbc6844aa29a98528b.tar.bz2
aports-b1b9ca2e4e443f2914c48ffbc6844aa29a98528b.tar.xz
community/soundtouch: remove -Ofast
-rw-r--r--community/soundtouch/APKBUILD4
-rw-r--r--community/soundtouch/no-fast.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/community/soundtouch/APKBUILD b/community/soundtouch/APKBUILD
index 6f04fcaf3f3..44b404b243e 100644
--- a/community/soundtouch/APKBUILD
+++ b/community/soundtouch/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=soundtouch
pkgver=2.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="Audio Processing library for changing Tempo, Pitch and Playback Rates"
url="http://www.surina.net/soundtouch/"
arch="all"
@@ -10,6 +10,7 @@ makedepends="cmake samurai"
subpackages="$pkgname-dev"
source="https://www.surina.net/soundtouch/soundtouch-$pkgver.tar.gz
aarch64-neon.patch.noauto
+ no-fast.patch
"
builddir="$srcdir/$pkgname"
options="!check" # no tests
@@ -51,4 +52,5 @@ package() {
sha512sums="
72cd38f3e11f3c55ff7ed3691fd9a749a5f8d072e08ed03f2fd43a8664962138afaf3e4647116940e86f6ae374a1ba3bcd4b108280da29f3ffa6091cf383ea35 soundtouch-2.3.2.tar.gz
f32042e29c74a17df745c42ad3ebaf72a8c303f63e45cc8c5d467e4598fed0a51dab37885b5850d8c7ef2df4976c475eebb18c0517eeb2776a09ebb7376f922b aarch64-neon.patch.noauto
+4c46d42f07d4de27de7492e0f53c984949ce1724257e54947d85258bad7dd2373546b47590212a28a7c4d702acff83bed7e20dc2242f55f036296ce4e9b1d421 no-fast.patch
"
diff --git a/community/soundtouch/no-fast.patch b/community/soundtouch/no-fast.patch
new file mode 100644
index 00000000000..75602d3c971
--- /dev/null
+++ b/community/soundtouch/no-fast.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 14f23e8..993f0e1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,7 +7,7 @@ if(MSVC)
+ set(COMPILE_DEFINITIONS /O2 /fp:fast)
+ set(COMPILE_OPTIONS )
+ else()
+- set(COMPILE_OPTIONS -Ofast)
++ set(COMPILE_OPTIONS -O3)
+ endif()
+
+ #####################