aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-08 16:05:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-09 12:37:45 +0000
commitb21948ec042475a412a5cd636c05736e4604bcd2 (patch)
tree1331a6fe5c45c3cdc153a0fe3941094dc57f6383
parente0b74a131ccda97f0fa26c5ce106e87852b7e059 (diff)
main/atk: upgrade to 2.30.0
-rw-r--r--main/atk/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/main/atk/APKBUILD b/main/atk/APKBUILD
index b9b7d32f77b..5fb9f044a92 100644
--- a/main/atk/APKBUILD
+++ b/main/atk/APKBUILD
@@ -1,38 +1,38 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=atk
-pkgver=2.28.1
+pkgver=2.30.0
pkgrel=0
pkgdesc="A library providing a set of interfaces for accessibility"
url="https://www.gtk.org/"
arch="all"
license="LGPL-2.0-or-later"
depends=""
-makedepends="glib-dev gobject-introspection-dev musl-utils"
+makedepends="glib-dev gobject-introspection-dev musl-utils meson ninja gtk-doc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ mkdir -p "$builddir"/build
+ cd "$builddir"/build
+ meson \
--prefix=/usr \
- --enable-introspection
- make
+ --buildtype=release \
+ --sysconfdir=/etc \
+ -Ddocs=true \
+ ..
+ ninja
}
check() {
- cd "$builddir"/tests
- # There is no test suite runner present, but the tests are built..
- for testapp in testdocument testrelation testrole teststateset testvalue; do
- ./$testapp
- done
+ cd "$builddir"/build
+ ninja test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ cd "$builddir"/build
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
+ DESTDIR="$pkgdir" ninja install
}
-sha512sums="aa61e7718b3f4d9c33ec2b4747e35f894a51550ef39ecc4a7af5705811c029645bd3c728071f446b075a0b7aef0c35c1b73406a210cd30171838f24a8dfc0abb atk-2.28.1.tar.xz"
+sha512sums="03f311378fdb91442f27ed542fa36edd2c9c036837c9f25ff37468bf7f743277d0b9253621563d15894e0da9d37e8df0a0e2c0e47e6aae33a38b13744c3b8b8e atk-2.30.0.tar.xz"