aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-07-22 20:01:03 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-07-22 20:02:12 +0200
commitb25c6a8afb2f581d13f284803e9e6e3806a617ab (patch)
tree6caad39103845ef2acb1c0457f15c7dff3170f26
parenta5e151957b5db090e13f1123f40342e1081f34ea (diff)
community/lua-depgraph: install minimal rock_manifest
-rw-r--r--community/lua-depgraph/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/lua-depgraph/APKBUILD b/community/lua-depgraph/APKBUILD
index a7d15f536af..deef5d5d484 100644
--- a/community/lua-depgraph/APKBUILD
+++ b/community/lua-depgraph/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lua-depgraph
_pkgname=depgraph
pkgver=0.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="A library and CLI tool for analyzing graph of dependencies between Lua modules"
url="https://github.com/mpeterv/depgraph"
arch="noarch"
@@ -52,10 +52,14 @@ _subpackage() {
depends="lua$lver lua$lver-filesystem"
install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
local lmod_dir="$subpkgdir/usr/share/lua/$lver"
+ local rockdir="$subpkgdir/usr/lib/luarocks/rocks-$lver/$_pkgname/$pkgver-1"
cd "$builddir"
mkdir -p "$lmod_dir"
cp -r src/$_pkgname "$lmod_dir"/
+
+ mkdir -p "$rockdir"
+ echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
sha512sums="2ea8f2907da25cf17754f1a526f390a7e532644198c03fecdf1b8ffd48c7737464b80046b9b088554abeb3f05b026f9ebdfc07a1977dc84b19e32ad418f15e4a lua-depgraph-0.1.1.tar.gz"