aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-06 20:03:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-07 01:03:54 +0000
commitb2d915e44eb51cc3c206fcbb30a641d3468d3f00 (patch)
tree500de48cfa181a3da02edd78f21f5578009b2e4c
parent8b669b8580e9c35465cd9da71e7ef1da33595e6b (diff)
community/lab: upgrade to 0.18.0
-rw-r--r--community/lab/APKBUILD33
1 files changed, 7 insertions, 26 deletions
diff --git a/community/lab/APKBUILD b/community/lab/APKBUILD
index 4b6591720df..825e133adc5 100644
--- a/community/lab/APKBUILD
+++ b/community/lab/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=lab
-pkgver=0.17.2
-pkgrel=1
+pkgver=0.18.0
+pkgrel=0
pkgdesc="A Git Wrapper for GitLab"
url="https://zaquestion.github.io/lab/"
arch="all !mips64" # limited by go
@@ -11,12 +11,12 @@ depends="git"
makedepends="go"
checkdepends="bash"
subpackages="
- $pkgname-bash-completion:bashcomp:noarch
- $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-bash-completion
+ $pkgname-zsh-completion
"
source="lab-$pkgver.tar.gz::https://github.com/zaquestion/lab/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/zaquestion/$pkgname"
-options="net !check" # Tests require configured GitLab account with SSH keys
+options="net !check chmod-clean" # Tests require configured GitLab account with SSH keys
export GOPATH="$srcdir"
export CGO_ENABLED=0
@@ -36,29 +36,10 @@ build() {
package() {
install -Dm755 "$builddir"/bin/$pkgname \
"$pkgdir"/usr/bin/$pkgname
-}
-
-cleanup_srcdir() {
- go clean -modcache
- default_cleanup_srcdir
-}
-
-bashcomp() {
- depends=""
- pkgdesc="Bash completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
-
install -Dm644 "$builddir"/lab.bash \
- "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
-}
-
-zshcomp() {
- depends=""
- pkgdesc="Zsh completions for $pkgname"
- install_if="$pkgname=$pkgver-r$pkgrel zsh"
-
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
install -Dm644 "$builddir"/_lab.zsh \
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="a35dc286b3eca61f2bed8bdea485181a428d50e6584f209a74d92267956e104cb8d37844cb43d5c2422845630db2fea6d37cb99884a705bdfeba88b29ecb195e lab-0.17.2.tar.gz"
+sha512sums="1559cde46144a830d2b3b30ee9e334d387112ca4a9aa50faf6de01099705c02da87197355184dc5d520360b2fc9f6e3d297a094f6befc0cc2505b904b9291773 lab-0.18.0.tar.gz"