aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2022-01-11 21:32:10 +0200
committerAndy Postnikov <apostnikov@gmail.com>2022-01-12 00:02:59 +0000
commitb2ea131ab631c31585e5acee4a538155bf774436 (patch)
tree080bb10d7fdbe0c8a41fe75669c8867087348bce
parent835ae3c6047be29052b3031f3261ccd26cc8a8a0 (diff)
testing/php81-pecl-imagick: upgrade to 3.7.0
-rw-r--r--testing/php81-pecl-imagick/APKBUILD13
-rw-r--r--testing/php81-pecl-imagick/fix-test.patch45
2 files changed, 5 insertions, 53 deletions
diff --git a/testing/php81-pecl-imagick/APKBUILD b/testing/php81-pecl-imagick/APKBUILD
index e12437c2584..292dae4d82d 100644
--- a/testing/php81-pecl-imagick/APKBUILD
+++ b/testing/php81-pecl-imagick/APKBUILD
@@ -2,9 +2,8 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php81-pecl-imagick
_extname=imagick
-pkgver=3.7.0_rc1
-_pkgver=${pkgver/_rc/RC}
-pkgrel=1
+pkgver=3.7.0
+pkgrel=0
pkgdesc="PHP 8.1 extension provides a wrapper to the ImageMagick library - PECL"
url="https://pecl.php.net/package/imagick"
arch="all !x86" # https://gitlab.alpinelinux.org/alpine/aports/-/issues/12537
@@ -13,9 +12,8 @@ depends="php81-common imagemagick"
checkdepends="ghostscript-fonts"
makedepends="php81-dev imagemagick-dev"
subpackages="$pkgname-dev"
-source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$_pkgver.tgz
- fix-test.patch"
-builddir="$srcdir/$_extname-$_pkgver"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir/$_extname-$pkgver"
build() {
phpize81
@@ -40,6 +38,5 @@ package() {
}
sha512sums="
-b90364126e6b2ca9a2065fa4b93e902996a011bb45cbfa9f843a6307964d8108c778ef7af5132a325c35d2aeeea372356fe599a63e85464c25e0c83e6e4b000e php-pecl-imagick-3.7.0_rc1.tgz
-f91e3cb396cb2c0da045035f513185d3d7a50d1ba6abf7f26dd7557b8c19838c64b291cd5b518667e976d5324a8350a347923182fb59769c4d447bf20365fea1 fix-test.patch
+c84408e4e4a0c46d979240e06d58d264c6bb21f3b95e3d434c8a21cd808f6c495fd453ef9c07b5c44dac81c6f205b6697f8ecaf1a65a86ce4e9052328a389ebe php-pecl-imagick-3.7.0.tgz
"
diff --git a/testing/php81-pecl-imagick/fix-test.patch b/testing/php81-pecl-imagick/fix-test.patch
deleted file mode 100644
index 8e05b48c40b..00000000000
--- a/testing/php81-pecl-imagick/fix-test.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 9352cc3a587c91c155cfbc7ca4a2a3688d21b686 Mon Sep 17 00:00:00 2001
-From: Danack <Danack@basereality.com>
-Date: Fri, 7 Jan 2022 15:00:03 +0000
-Subject: [PATCH] Work around 4294967295 being above PHP_INT_MAX on 32bit arch.
-
----
- util/functions.php | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/util/functions.php b/util/functions.php
-index a57a2483..d69baf48 100644
---- a/util/functions.php
-+++ b/util/functions.php
-@@ -223,22 +223,22 @@ function get_epsilon_for_off_by_half_errors()
- {
- // These could be defined better...
- $epsilon_values_for_non_hdri = [
-- 255 => (1 / (pow(2, 8) - 1)) + 0.0000000000001,
-- 65535 => (1 / (pow(2, 16) - 1)) + 0.0000000000001,
-- 16777215 => (1 / (pow(2, 24) - 1) ) + 0.0000000000001,
-- 4294967295 => (1 / (pow(2, 32) - 1)) + 0.0000000000001,
-+ '255' => (1 / (pow(2, 8) - 1)) + 0.0000000000001,
-+ '65535' => (1 / (pow(2, 16) - 1)) + 0.0000000000001,
-+ '16777215' => (1 / (pow(2, 24) - 1) ) + 0.0000000000001,
-+ '4294967295' => (1 / (pow(2, 32) - 1)) + 0.0000000000001,
- ];
-
- // These could definitely be defined better...
- $epsilon_values_for_hdri = [
-- 255 => 0.0000000000001,
-- 65535 => 0.0000000000001,
-- 16777215 => 0.0000000000001,
-- 4294967295 => 0.0000000000001
-+ '255' => 0.0000000000001,
-+ '65535' => 0.0000000000001,
-+ '16777215' => 0.0000000000001,
-+ '4294967295' => 0.0000000000001
- ];
-
- if (Imagick::getHdriEnabled() === false) {
-- $quantum = Imagick::getQuantum();
-+ $quantum = (string)Imagick::getQuantum();
- if (array_key_exists($quantum, $epsilon_values_for_non_hdri) !== true) {
- throw new Exception(
- "Quantum values is $quantum which is not any of (2^(8|16|24|32)) - 1. Please report this as a bug."