aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-14 14:03:08 -0300
committerAriadne Conill <ariadne@dereferenced.org>2020-12-15 14:30:31 +0000
commitb4b19f6d4867d0705f4bfab28ba22e5f04487fd7 (patch)
tree4aa32e58b4d1b99c20160ceb0515926dd4ab2600
parentaf7da72e07bd0af25cf2cdc3979a9e13dc65fcfd (diff)
community/olm: skip tests that require pytest-benchmark on mips64
pytest-benchmark is not available on mips64
-rw-r--r--community/olm/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/olm/APKBUILD b/community/olm/APKBUILD
index c44f99ada50..f61d3a5d789 100644
--- a/community/olm/APKBUILD
+++ b/community/olm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=olm
pkgver=3.2.1
pkgrel=0
pkgdesc="Implementation of the olm and megolm cryptographic ratchets"
-arch="all !mips64" # pytest-benchmark unavailable
+arch="all"
url="https://gitlab.matrix.org/matrix-org/olm"
license="Apache-2.0"
makedepends="
@@ -16,13 +16,21 @@ makedepends="
checkdepends="
py3-pytest
py3-pytest-cov
- py3-pytest-benchmark
py3-future
py3-aspectlib
"
source="https://gitlab.matrix.org/matrix-org/olm/-/archive/$pkgver/olm-$pkgver.tar.gz"
subpackages="$pkgname-dev py3-olm:py3"
+case "$CARCH" in
+ mips*)
+ _disable_tests="
+ --deselect tests/group_session_test.py::TestClass::test_encrypt \
+ --deselect tests/group_session_test.py::TestClass::test_decrypt"
+ ;;
+ *) checkdepends="$checkdepends py3-pytest-benchmark" ;;
+esac
+
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
@@ -44,7 +52,8 @@ check() {
# give the ffi it just built with a link,
# and the C libolm with the ld environment variable
ln build/lib.linux-*/_libolm*.so tests/_libolm.so
- LD_LIBRARY_PATH="$builddir/build/lib" PYTHONPATH="$PWD" pytest
+ LD_LIBRARY_PATH="$builddir/build/lib" PYTHONPATH="$PWD" pytest \
+ -c /dev/null $_disable_tests
}
package() {