aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2021-10-16 18:30:53 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2021-10-16 18:34:25 +0000
commitb56c0351e62c875a03b4c0b681e92f23e3621384 (patch)
treeea0fac3e430a17136bd2e6991e5caca16b5200d1
parent160b90580f4efbfaf71ebc5cb7e41dece40ccd84 (diff)
downloadaports-b56c0351e62c875a03b4c0b681e92f23e3621384.tar.gz
aports-b56c0351e62c875a03b4c0b681e92f23e3621384.tar.bz2
aports-b56c0351e62c875a03b4c0b681e92f23e3621384.tar.xz
community/ntpsec: support running as non-root user
ntpsec allows running as non-root, but for that to work, it needs to be built against libcap. Without libcap, it cannot run as a non-root user. Add support for this by adding libcap-dev as makedepend. Fixes #13076
-rw-r--r--community/ntpsec/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/ntpsec/APKBUILD b/community/ntpsec/APKBUILD
index 1f9af64cbc..9d2e252c8a 100644
--- a/community/ntpsec/APKBUILD
+++ b/community/ntpsec/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer:
pkgname=ntpsec
pkgver=1.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="NTP reference implementation, refactored for security"
url="https://www.ntpsec.org/"
arch="all"
license="BSD-2-Clause"
depends="bash busybox python3 py3-gpsd"
-makedepends="python3-dev bison asciidoc openssl1.1-compat-dev linux-headers"
+makedepends="python3-dev bison asciidoc openssl1.1-compat-dev linux-headers
+ libcap-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="https://ftp.ntpsec.org/pub/releases/ntpsec-$pkgver.tar.gz"