aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2021-01-22 23:20:04 +0200
committerAndy Postnikov <apostnikov@gmail.com>2021-03-01 22:15:26 +0000
commitb57496515c67c32515c1c64922b3092919302d32 (patch)
treeca63cd2dcfa7f030fb7d3e396724f261e1cd69bc
parent4b7570a994ca2222c242299175a092fd6417a09b (diff)
testing/php8-pecl-smbclient: new aport
-rw-r--r--testing/php8-pecl-smbclient/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/php8-pecl-smbclient/APKBUILD b/testing/php8-pecl-smbclient/APKBUILD
new file mode 100644
index 00000000000..9d380850dd8
--- /dev/null
+++ b/testing/php8-pecl-smbclient/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+
+pkgname=php8-pecl-smbclient
+_extname=smbclient
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="PHP 8 extension that uses Samba's libsmbclient library to provide Samba related functions and 'smb' streams to PHP programs."
+url="https://pecl.php.net/package/smbclient"
+arch="all"
+license="BSD-2-Clause"
+depends="php8-common"
+makedepends="php8-dev samba-dev"
+source="php-pecl-$_extname-$pkgver.tgz::https://pecl.php.net/get/$_extname-$pkgver.tgz"
+builddir="$srcdir"/$_extname-$pkgver
+
+build() {
+ phpize8
+ ./configure --prefix=/usr --with-php-config=php-config8
+ make
+}
+
+check() {
+ # Test suite require phpunit to run.
+ php8 -d extension=modules/$_extname.so --ri smbclient
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ local _confdir="$pkgdir"/etc/php8/conf.d
+ install -d $_confdir
+ echo "extension=$_extname" > $_confdir/$_extname.ini
+}
+
+sha512sums="381051dbe6347ce3b0be9d1ed44ee80be846ce1cd4255689127220a48e3c157853e98ae463435a12342f6370b4e96c162069d8d00574aaf88675c5b9ad0810e8 php-pecl-smbclient-1.0.6.tgz"