aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorptrcnull <git@ptrcnull.me>2023-01-19 22:01:25 +0100
committerPatrycja Rosa <alpine@ptrcnull.me>2023-01-27 22:03:11 +0000
commitb5cbf617f9084f40022908f4930b095f7176eb43 (patch)
tree77f32ff1377e0893a0ee70635d25eec6ee491dbd
parentf042a6c0526eb4a35c655cb7a5c8203f21fca026 (diff)
downloadaports-b5cbf617f9084f40022908f4930b095f7176eb43.tar.gz
aports-b5cbf617f9084f40022908f4930b095f7176eb43.tar.bz2
aports-b5cbf617f9084f40022908f4930b095f7176eb43.tar.xz
community/py3-confuse: upgrade to 2.0.0
-rw-r--r--community/py3-confuse/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/py3-confuse/APKBUILD b/community/py3-confuse/APKBUILD
index dcc2abdedf5..7263d0656f0 100644
--- a/community/py3-confuse/APKBUILD
+++ b/community/py3-confuse/APKBUILD
@@ -1,21 +1,22 @@
# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
pkgname=py3-confuse
-_pyname=confuse
-pkgver=1.7.0
-pkgrel=1
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Painless YAML config files for Python"
url="https://github.com/beetbox/confuse"
arch="noarch"
license="MIT"
depends="python3 py3-yaml"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-flit-core py3-installer"
checkdepends="py3-nose"
-source="confuse-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
-builddir="$srcdir/$_pyname-$pkgver"
+source="confuse-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/confuse/confuse-$pkgver.tar.gz"
+builddir="$srcdir/confuse-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -23,9 +24,10 @@ check() {
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ dist/confuse*.whl
}
sha512sums="
-c48cf13a7e3f8287ee1255f3d7f6d65e709532a8ae87a1ba937d0032556e45b97a154c59f71436fd1776c136b9e5c5ccac7e1795f288efece540acc926da5b1f confuse-1.7.0.tar.gz
+1faf4f1ec5c7429d9e3e88157bfd1e4fac5d3b449ceaedbe909f382f4bd1d049518ca526dbfcd0b8bc2311de1a1941821ba26c1cce84cd412fb3ae007f9d8f1b confuse-2.0.0.tar.gz
"